Subharmonicon and DFAM out of sync

Mother-32, DFAM, Subharmonicon, Grandmother, Matriarch
Post Reply
natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Subharmonicon and DFAM out of sync

Post by natehorn » Mon Feb 22, 2021 3:33 am

I'm trying to clock the DFAM from the Subharmonicon's 'SEQ 2 CLK' output but there's a weird delay. Basically the DFAM triggers moments after the Subharmonicon, rather than at the same time. So they're running at the same BPM but aren't really in sync - it seems the DFAM is only advancing *after* SEQ 2 CLK advances - not with it, like a ghost note.

Is this intended, am I doing something wrong? Some other weirdness happening here?

User avatar
MRNUTTY
Posts: 301
Joined: Fri May 02, 2014 2:54 pm

Re: Subharmonicon and DFAM out of sync

Post by MRNUTTY » Wed Feb 24, 2021 7:37 pm

If a clock is programmed, there is zero* delay between trigger, or clock, clk1, clk2 outputs.


*- one to two microseconds.
VoyagerEB, Minitaur, LittlePhattyII, 4xSlimPhatty, Sub37, MF[2x101,2x102,103,104M,105,105B,105M,2x107,108M], 3xCP251, XV351, MP201;
2xMother 32, DFAM, Subharmonicon;
System 55 and Minimoog clones with lots of mods.

natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Re: Subharmonicon and DFAM out of sync

Post by natehorn » Thu Feb 25, 2021 2:01 am

- Deleted -
Last edited by natehorn on Thu Feb 25, 2021 12:33 pm, edited 1 time in total.

natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Re: Subharmonicon and DFAM out of sync

Post by natehorn » Thu Feb 25, 2021 3:31 am

Here is a video where I think it's clear you can see what I describe in the way the sequencers move together, the DFAM is clearly lagging behind the second sequencer of the Subharmonicon.

https://youtu.be/ehelH2pkxZk

Note that although the midi cable is plugged in I tried it without as well and it didn't make any difference.

natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Re: Subharmonicon and DFAM out of sync

Post by natehorn » Thu Feb 25, 2021 12:31 pm

I just tracked down this Reddit post from 8 months ago where other users are discussing this problem, seems it's an issue Moog have recognised and are hoping to fix. I'm really hoping they can fix it, seems like a long time to address a problem that has essentially rendered 2 of the outputs as duds :(

https://www.reddit.com/r/modular/commen ... t_in_sync/

User avatar
MRNUTTY
Posts: 301
Joined: Fri May 02, 2014 2:54 pm

Re: Subharmonicon and DFAM out of sync

Post by MRNUTTY » Fri Apr 16, 2021 1:09 pm

natehorn wrote: Thu Feb 25, 2021 3:31 am Here is a video where I think it's clear you can see what I describe in the way the sequencers move together, the DFAM is clearly lagging behind the second sequencer of the Subharmonicon.

https://youtu.be/ehelH2pkxZk

Note that although the midi cable is plugged in I tried it without as well and it didn't make any difference.
Sorry for the delay getting back. I saw the video, and rigged up the same 'patch'. My DFAM and SubH SEQ 2 CLK are right on target; both visually - at watchable speeds - and on a scope at faster speeds. Only 1us or so latency between clocks. So it got fixed somewhere along the line. My SubH is fairly new.
VoyagerEB, Minitaur, LittlePhattyII, 4xSlimPhatty, Sub37, MF[2x101,2x102,103,104M,105,105B,105M,2x107,108M], 3xCP251, XV351, MP201;
2xMother 32, DFAM, Subharmonicon;
System 55 and Minimoog clones with lots of mods.

natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Re: Subharmonicon and DFAM out of sync

Post by natehorn » Fri Apr 16, 2021 2:03 pm

Would be great to hear from Moog on the issue, they seem incredibly choosey about what support tickets they respond to.

joeel
Posts: 5
Joined: Thu May 13, 2021 5:20 pm

Re: Subharmonicon and DFAM out of sync

Post by joeel » Thu May 13, 2021 5:31 pm

Yes, this happens to me often. It is a bug that happens every now and then - probably because of some other thing I did without thinking about it. It goes away, sometimes after a restart, sometimes not. Sometimes it's gone next morning if I leave it off over the night. Very annoying and I do hope they fix it soon

natehorn
Posts: 9
Joined: Mon Feb 22, 2021 3:28 am

Re: Subharmonicon and DFAM out of sync

Post by natehorn » Fri May 14, 2021 7:29 am

That's interesting, Ive never noticed them working correctly but I avoid them due to this issue.

Funnily enough I heard from Moog yesterday on this and they did confirm they're aware of the issue and plan to fix it in a future firmware update. No ETA though - which is a bit disappointing - 3 years is a long time to fix a bug.

joeel
Posts: 5
Joined: Thu May 13, 2021 5:20 pm

Re: Subharmonicon and DFAM out of sync

Post by joeel » Mon May 17, 2021 7:30 am

Just to be clear - I believe this is an issue with the Subharmonicon SEQ1/2 CLK outputs. It happens even if DFAM is not involved. Try for example patching SEQ2 CLK to TRIGGER on Subharmonicon only and you will eventually get this bug there too.

As for your question PaulKaul - midi clocks generally work fine for me

Mr Chitlun
Posts: 1
Joined: Mon May 17, 2021 8:57 am

Re: Subharmonicon and DFAM out of sync

Post by Mr Chitlun » Mon May 17, 2021 9:03 am

Hi all. Newbie here… Just to confirm Joeel’s post, I have tried the SubH Seq 1&2 outs with a couple of other synths and there is a distinct delay when dividing the clock. Absolutely bang on when there’s no division but as soon as I divide, it goes off. This is definitely not exclusive to the DFAM.

Post Reply