Mother 32 not working in my Eurorack

Mother-32, DFAM, Subharmonicon, Grandmother, Matriarch
Post Reply
brento73
Posts: 1
Joined: Wed Apr 07, 2021 9:47 pm

Mother 32 not working in my Eurorack

Post by brento73 » Wed Apr 07, 2021 9:52 pm

I've seen some other posts adjacent to this, but nothing where someone had this exact problem.

When I plug my Mother 32 into the power ribbon cable in my eurorack, the entire case stops powering on. The Mother 32 seems to work fine in it's own case.

To be clear, I follow this process:

Shut down my rack
Plug the ribbon cable into the power bus and the Mother 32, the bus is keyed and the Mother 32 has a handy diagram, so I know I have the orientation correct
Turn on my rack

The result is that nothing in the entire system works. I've tried different cables, and different points on the bus, and it still doesn't work.

Thankfully, removing the Mother 32 allowed everything else(including a Subharmonicon) to start working as expected.

I've checked that my case is rated for way more power than everything is drawing.

Hopefully, someone here will have some ideas.

User avatar
MRNUTTY
Posts: 298
Joined: Fri May 02, 2014 2:54 pm

Re: Mother 32 not working in my Eurorack

Post by MRNUTTY » Thu Apr 08, 2021 4:26 pm

Many power supplies are spec'd way over what they can deliver.

Had the same issue racking up two M32's, DFAM, and SubH. The DFAM and SubH wouldn't run on a single 4MS supply spec'd more than enough to run them, and a couple of other modules.

Does the M32 run in your eurorack case with the other modules disconnected instead? If so, plug in your module's one at a time to see when it stops working. It will probably be flaky before it just doesn't come on, but you can gauge how much more power you need with smaller module increments.
VoyagerEB, Minitaur, LittlePhattyII, 4xSlimPhatty, Sub37, MF[2x101,2x102,103,104M,105,105B,105M,2x107,108M], 3xCP251, XV351, MP201;
2xMother 32, DFAM, Subharmonicon;
System 55 and Minimoog clones with lots of mods.

Post Reply