Need Sub Phatty editor and firmware update any news?

Everything Sub.
Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Thu Oct 16, 2014 12:19 pm

Amos wrote: when the driver is installed, does *ANYTHING* show up in the device list? Do you see a device with the names MIDI IN and MIDI OUT, by any chance?
Yes, my other USB devices show up in the list (Launchpad, MOTU soundcard, etc).
Hope that is helpful info :)

Rokatansky
Posts: 36
Joined: Thu May 23, 2013 4:43 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Rokatansky » Thu Oct 16, 2014 2:11 pm

- installed new firmware
- then checked via standalone editor: yes, running v2.0.6.
- installed the new USB MIDI driver
- then checked via standalone editor: no. "hardware disconnected".
- restarted both computer and Sub Phatty
- checked again via standalone editor: nope. hardware disconnected.
- checked via VSTi: same. disconnected.
- uninstalled the new USB MIDI driver, and restarted moog.
- basic usb driver was successfully re-installed.
- checked via standalone editor: connected.
- checked via VSTi: no. hardware disconnected.

So, the new USB midi driver didn't do me any good at all,
because now it is even worse than before (the VSTi used to work up until this point).
Same here the new USB driver causes the Sub Phatty to be not recognized.
Removing the new USB driver and everything work fine.
WIn 7 64 SP1 Cubase 7.5 PT 11
Last edited by Rokatansky on Mon Oct 27, 2014 2:08 pm, edited 1 time in total.

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Mon Oct 20, 2014 10:18 am

Rokatansky wrote: Same here the new USB driver causes the Sub Phatty to be not reconized.
Removing the new USB driver and everything work fine.
WIn 7 64 SP1 Cubase 7.5 PT 11
Hey, glad to hear I'm not the only one, sort of ;)
Rokatansky, have you also experienced problems with automating more than 2 parameters using the VI-instrument in your DAW?

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Mon Oct 27, 2014 8:16 am

bump

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Fri Oct 31, 2014 5:30 pm

Hi Denim, don't give up hope.

Same for soundremo, Rokatansky, and any others who are waiting for a better-working Sub Phatty editor.

Here is a newer build of the Windows plugin... this is primarily to see if it appears in the DAW for any users who were not seeing it previously.... please let me know.

http://www.moogconnect.net/downloads/su ... WS-VST.zip

Denim, I read that your problem with automating more than one parameter at a time seemed to be linked to using a USB3 port, and you didn't have the same problem on USB2 port, correct?

..but now on USB2 port you are getting "disconnected" message frequently? Hmm... and you're using firmware v2.0.6?
I'll write more next week... I may need your help (or someone else's) to test a debug version of the USB driver, to find out why it's not working properly on your system.

Until soon,

Amos

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Tue Nov 04, 2014 4:45 am

Hi Amos, thanks for the update. I won't be able to test the new VI build until next week, but I will write back here then, and I'd be happy to test stuff / help out finding the bugs.

nolongerhuman
Posts: 3
Joined: Sun Aug 24, 2014 2:27 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by nolongerhuman » Thu Nov 06, 2014 1:09 am

It's really odd that apparently the version of the editor sent when registering isn't apparently the newest version, and, it seems impossible to find the newest version. Sigh.

Anyway, I am having issues with the disconnected message, using Ableton Live on a Mac running Mavricks. In Live itself, the editors says disconnected, though the knobs do effect the proper functions, the library functions for selecting or saving sounds do not work, in stand alone mode, nothing at all works.
I have the newest firmware installed and version 2.0 of the editor. Can anyone link me to a more stable editor version?

This is actually really odd, and a first experience with Moog stuff not working as expected, i've owned most of the Moog synth line, and this is the first time I have been kind of let down so far. :( The synth is awesome. The editor... is broken.

Tpulse
Posts: 13
Joined: Sat Mar 22, 2014 9:58 pm
Location: Sweden
Contact:

Re: Need Sub Phatty editor and firmware update any news?

Post by Tpulse » Thu Nov 06, 2014 7:00 am

The Subphatty VI plugin works for me in REAPER, finally :P, just add the plug, and set the audio input..it works, tried also a few cc parameter (filter, decay etc.) automation and it seems to work :) have to try it for a few Days now :)
i'll write down some issues below:

Subphatty don't like when using this:
- Keyboardoct automation

dhocks76
Posts: 30
Joined: Mon Jul 08, 2013 6:55 am

Re: Need Sub Phatty editor and firmware update any news?

Post by dhocks76 » Sat Nov 08, 2014 5:39 am

where can I find the latest version of the 'Mac' Sub phatty editor?
**edit** I have 1.1.0 is that the most recent one?

User avatar
till
Posts: 1203
Joined: Tue Nov 22, 2005 6:17 pm
Location: south-west Germany
Contact:

Re: Need Sub Phatty editor and firmware update any news?

Post by till » Sun Nov 09, 2014 5:42 am

Hi dhocks76,
version 1.1.0 is the most recent one for the Mac.
keep on turning these Moog knobs

Sequence:
Prodigy * minimoog '79 * Voyager * MF102 * MF103 * MF104z * MP201 * Taurus 3 * Minitaur * Sub Phatty * MF105 * Minimoog 2017+ MUSE * One 16

Rokatansky
Posts: 36
Joined: Thu May 23, 2013 4:43 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Rokatansky » Mon Nov 10, 2014 3:40 pm

I assume VI is Virtual instrument,right?
Well Cubase 7.5 didn't see it after move it to the vst folder.

The "FX" editor seems to work fine.

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Fri Nov 14, 2014 9:25 am

Hi Amos

I have tested some more now with the latest plugin builds you shared (October 2014 build), here are my results:

VSTi (VI) - 64-bit:
- loads fine in DAW, editor showing firmware 2.0.6 and editor version 1.1.0
- but then: after 2-3 minutes I get "hardware disconnected" again.
- further i see in Windows Task Manager that the process "Sub Phatty MidiPortHandler.exe *32" now is stuck, even after closing DAW and shutting off the synth
- killed the process, restarted synth and DAW = same result after 2-3 minutes.
- automation of more than 2 parameters: I managed to automate 3 parameters without glitching, seemed to work better now, but because it crashes after a short while I am not sure if it is solved, needs more testing.

Q: Could the fact that "Sub Phatty MidiPortHandler.exe" is running in 32-bit mode, and everything else in 64-bit - cause problems?

So a short summary:
- March 2014 build of the VI: most stable version (not getting hardware disconnected), but automation of more than 2 parameters causes glitching.
- October 2014 build of the VI: hardware disconnected after 2-3 minutes, but automation seems to work better.
- Custom moog USB driver: does not work at all for me (Phatty not showing up in midi device lists).

This is all tested running:
- Sub Phatty connected to native USB 2.0 port (earlier USB 3.0, but switched to a 2.0 port because it generally seemed way more stable).
- Firmware 2.0.6
- 64-bit versions of the plugins (VI + VST)
- Win 7 64-bit with SP1, running Renoise 64-bit.
- NOT RUNNING: the custom moog USB driver for windows.

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Wed Nov 19, 2014 5:55 pm

Amos, was some of this ^ helpful? Let me know if you need me for more testing, I have plenty of time the next 4 days.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Thu Nov 20, 2014 1:07 pm

Hi, thanks for the detailed feedback! It's definitely helpful. I will work through it and be back in touch ASAP.

All the best,

Amos

DiScO197
Posts: 17
Joined: Mon Aug 05, 2013 1:00 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by DiScO197 » Sat Feb 21, 2015 8:14 am

Any advance on this?

I am using a Mac Pro late 2013 (Yosemite 10.10.2) with the 2.0.6 firmware and 1.1.0 editor and I constantly get hanging notes (when changing patches from the librarian) and frequent hardware disconnects. Would really appreciate this getting some attention. It's just frustrating as I sit and watch my warranty expire with the potential of a hardware problem.

Many thanks.

Post Reply