3.1 Slim Phatty update gone awry...

Everything Phatty.
Post Reply
Posts: 2
Joined: Tue Feb 14, 2012 8:47 pm

3.1 Slim Phatty update gone awry...

Post by iamgoldman » Tue Feb 14, 2012 8:55 pm

I've been doing some searching on here and I have not seen anyone else with this problem...

I bought a Slim Phatty recently. Found out there was a firmware update, so I chose to install it. However, after following all instructions and going through the whole procedure, after the update, the functions of the buttons on my SP's panel are all mixed up (eg, pressing MASTER activates CURSOR, pressing OSC 2 FREQ activates OSC 1+2 SYNC).

Updated on Windows 7, 64-bit via USB

I've tried re-updating several times after restoring factory settings on the SP
I've tried running the phatty loader at the slowest speeds
I've led to the same result every time.


Sir Nose
Posts: 1024
Joined: Sat Sep 20, 2008 11:15 am

Re: 3.1 Slim Phatty update gone awry...

Post by Sir Nose » Wed Feb 15, 2012 11:32 am

Did you power cycle the unit after the update?

Weird problem. You can contact Moog support by email or phone. They are usually very helpful.

Posts: 99
Joined: Wed Jul 23, 2003 9:48 am

Re: 3.1 Slim Phatty update gone awry...

Post by SteveD » Wed Feb 15, 2012 6:36 pm

Did you install a Little Phatty update on a Slim Phatty?
button assignments are different in the two units - maybe that's what happened....
Check the file you downloaded from the website - it should be

Slim_Phatty_v3_1_672_Update_OSX_0.zip (Mac OS)
Slim_Phatty_v3_1_672_Update_WIN_0.zip (Windows)


Post Reply