Dropped and stuck notes even with new firmware

Everything Phatty.
aldegra
Posts: 2
Joined: Thu Feb 23, 2012 7:02 pm

Re: Dropped and stuck notes even with new firmware

Post by aldegra » Thu Feb 23, 2012 7:35 pm

I'm also having stuck note problems with my SP. I am using a BOSS DR-5 as my midi controller because I love the guitar-oriented pad layout. I'm getting stuck note problems with just DIN MIDI OUT of the DR-5 to DIN MIDI IN on the SP. These problems go away if change the setting on the DR-5 from MIDI Sync: INTERAL to MIDI Sync: MIDI. I assume this is because then the DR-5 is no longer sending any clock messages, and it now requires another clock to control it. (I gathered from other posts that clock messages were linked to the stuck notes problem). I consider this only a temporary solution because I would like to use DR-5 to send intended clock messages, control it's own tempo, start it's own sequences, etc.

After much time spent testing different settings, I also found that there are no stuck notes when Polychain is on (even "1 of 1").

When a note is stuck, I can unstick it by changing the LOCAL CONTROL setting to ON or OFF, but I will get stuck notes when I start from either one of these settings.

I can also stop a stuck note with the ALL NOTES OFF thing.

I'm hoping the new USB update will allow me to use the SP with my DR-5, for I don't have much interest in any other MIDI controller (I haven't gotten around to testing any others with SP either).

BIG UPS AND RESPECT.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Dropped and stuck notes even with new firmware

Post by Amos » Fri Feb 24, 2012 6:16 pm

screenliar wrote:And will the minitaur have stuck notes and other horrible things as well.
Nope. No stuck notes on Minitaur when controlling via MicroKorg or anything else we've tried.

Minitaur is shipping today so I am back working on the SP USB update.

The weird thing is that I *am* getting successful updates to USB firmware v34 using the file that folks have said does not work for them. The key is, it does *not* display a "USB UPGRADED" message when the update is complete. I will describe exactly what I am seeing here when I do the update, and I would ask anyone with an SP and a Windows computer who cares to try it, to see if they can reproduce my results.

So, here's what I am doing:

Start with SP running main firmware v3.12 (680) and USB firmware v31.
Connect USB from Slim to computer
Launch SLIM_USB_v34.exe on my Windows computer
type the number corresponding to the slim ('usb audio device' on winxp) and press enter
wait about 5 seconds and the computer will show that the transfer is complete.
wait about 30 more seconds - the Phatty is actually transmitting the USB firmware out its MIDI output at this time. This is only useful here at the Moog factory, but that's what it's doing.
Make sure the SP is on PRESET/panel display - you should now see the "midi activity" icon flashing on the SP display for another 20 seconds or so.
turn off the Phatty, turn it back on.

Check the System Utilities page on the master menu - USB firmware now shows v34. Upgrade was successful.

So, I'm working on making it show the 'USB UPGRADED' message on the LCD, but the important fact here is that the update actually worked.

Can anyone else try this and report back? Keep in mind that it doesn't show a confirmation message and you should wait about a minute after sending the firmware to power down. If after about 30 seconds you see the midi activity indicator blinking on the LCD, then it probably worked fine...

here's the file again for anyone who wants to give it a go:

http://seamslikereality.com/moog/SLIM_USB_v34.zip

hackbar
Posts: 16
Joined: Mon Oct 24, 2011 2:02 pm

Re: Dropped and stuck notes even with new firmware

Post by hackbar » Fri Feb 24, 2012 7:29 pm

Amos wrote: The weird thing is that I *am* getting successful updates to USB firmware v34 using the file that folks have said does not work for them. The key is, it does *not* display a "USB UPGRADED" message when the update is complete. I will describe exactly what I am seeing here when I do the update, and I would ask anyone with an SP and a Windows computer who cares to try it, to see if they can reproduce my results.
I ran the update, and this was the behavior I noticed. No "USB UPGRADED" message, but the version showed as 34. I didn't look at the midi indicator light though, so I'm not sure what it did during the upgrade.

However, even after that, I didn't see a fix for the stuck notes. I'm still getting them. However, I found my controller sends ACTIVE_SENSE, and if I use a computer to filter out those messages, the problem seems to go away.

vertibration
Posts: 17
Joined: Sat Feb 11, 2012 7:33 pm

Re: Dropped and stuck notes even with new firmware

Post by vertibration » Fri Feb 24, 2012 9:37 pm

Amos,

The firmware update works, Ableton has stuck notes, but logic works fine. Its weird cause it only goes haywire in Ableton. Its picture perfect in logic, even though i ran into a small bump in my previous post about running in logic, i found that it was a mistake on my end. So why would logic be ok, and not ableton?

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Dropped and stuck notes even with new firmware

Post by Amos » Fri Feb 24, 2012 11:06 pm

hackbar wrote:
Amos wrote: The weird thing is that I *am* getting successful updates to USB firmware v34 using the file that folks have said does not work for them. The key is, it does *not* display a "USB UPGRADED" message when the update is complete. I will describe exactly what I am seeing here when I do the update, and I would ask anyone with an SP and a Windows computer who cares to try it, to see if they can reproduce my results.
I ran the update, and this was the behavior I noticed. No "USB UPGRADED" message, but the version showed as 34. I didn't look at the midi indicator light though, so I'm not sure what it did during the upgrade.

However, even after that, I didn't see a fix for the stuck notes. I'm still getting them. However, I found my controller sends ACTIVE_SENSE, and if I use a computer to filter out those messages, the problem seems to go away.
Thanks for this. It sounds like Active Sensing is another unhandled case. I apologise, this is very old code written before my time at Moog, and it's a real challenge to modify. It is getting better each time though. I'll fix ACTIVE_SENSE next week, stand by and thanks for your patience.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Dropped and stuck notes even with new firmware

Post by Amos » Fri Feb 24, 2012 11:12 pm

vertibration wrote:Amos,

The firmware update works, Ableton has stuck notes, but logic works fine. Its weird cause it only goes haywire in Ableton. Its picture perfect in logic, even though i ran into a small bump in my previous post about running in logic, i found that it was a mistake on my end. So why would logic be ok, and not ableton?
I get stuck notes in Ableton sometimes and I think it's Live's fault... like when I hit stop it doesn't always necessarily send a note-off for notes it was in the middle of playing... and sometimes it sends an extra midi clock AFTER the midi STOP message when you stop the transport. There are just a few little dodgy things about its MIDI implementation that have persisted through numerous updates. I love the software but I don't necessarily trust it to work perfectly.

That being said, it could also be the Phatty's fault in this case.. or something about the way it's set up... for instance are you echoing MIDI from the phatty in to live and back out to the phatty? That's sometimes a problem, unless local control is turned off...

looks like I'll have a new version to test next week. If you're still getting stuck notes let's look more into the particular setup where it happens and see if we can determine the cause.

-Amos

Spitfire
Posts: 142
Joined: Mon May 23, 2011 8:07 pm

Re: Dropped and stuck notes even with new firmware

Post by Spitfire » Sat Feb 25, 2012 2:14 am

Amos,

Thanks for your hard work. Moog provides the best customer service anywhere and I'm sure you're doing the best you can. In fact, the company's service is the second reason why almost all my synths are Moogs... second only to sonic and build quality.

I think guys in Amos and Rosser's line of work don't get enough credit.

Thanks for all the hard work.

Cheers,

A proud owner of 2 LPs and one lunar impact minimoog voyager.
Minimoog Model D / Moog Little Phatty TE / DSI Prophet 08 / Elektron Digitone / Elektron Octatrack Mkii / Clavia Nord Wave / Nord Drum II / Clavia Nord Lead 3 / Roland TR-707 / Roland TB-03 / Korg MS-20 / Access Virus TI 2 Polar / Roland SH-101 /:mrgreen:

aldegra
Posts: 2
Joined: Thu Feb 23, 2012 7:02 pm

Re: Dropped and stuck notes even with new firmware

Post by aldegra » Sat Feb 25, 2012 3:00 pm

Thank you, Amos and others. I think you've solved the stuck notes problem with my BOSS DR-5! I no longer need to turn off all the clock messages in order to scream through the SP! Now, it's up to me to scorch the earth and melt faces with this thing. :twisted:

One other thing: I noticed you said you were using v3.12_380 firmware. Is that an upgrade from v3.1_376? That's what I have, and it's the latest I can find.

User avatar
bichuelo
Posts: 838
Joined: Fri Jan 22, 2010 5:25 pm
Location: Bogotá, Colombia
Contact:

Re: Dropped and stuck notes even with new firmware

Post by bichuelo » Sun Feb 26, 2012 11:41 pm

Well, I was able to install the USB update and now it shows 34, even though the firmware keeps being on 672.

Afterwards, I began to send MIDI Clock and Active Sense right away from my MC50mkII, in a setup where the phatty only uses the MIDI jacks and no USB. Actually both outputs are configured to be used as THRU, and it worked fine

This same setup was giving me stuck notes in the old version (only while I sent Clock and/or Active sensing).

So it looks like, even though is a USB update, it fixed the problems in my MIDI setup! Good work Amos! :mrgreen:
http://audiotecna.info
T-III, Voyager, VX-351, Slim Phatty, Model D, Sub Phatty, Subsequent 37, Minitaur, all moogerfoogers and minifoogers, EW+, Theremini, Model 15, Filtatron, Animoog, Model D App, iOS 11 Mother-32, DFAM, Werkstatt, Win7, High Sierra

User avatar
David Smyth
Posts: 297
Joined: Tue Jun 23, 2009 3:40 am
Location: Wellington, New Zealand
Contact:

Re: Dropped and stuck notes even with new firmware

Post by David Smyth » Mon Feb 27, 2012 5:05 pm

Hey Amos,

I have the new firmware on my LP St. II & SP's (v33 for LP, v34 for SP's). I'm trying to use my Korg KP3 Kaoss Pad to send midi clock (via midi din cable) to control the LP Arpeggiator and LFO rate (no SP's chained at this stage). The issue I'm getting is that the LFO rate is still controllable on the LP panel (in the LP menu, the LP panel rate should be inactive), but yet the KP3's tempo change effects the LP's LFO rate too. So when the KP3's tempo is 100BPM, the LP's LFO rate can still be changed from the panel - so it's not really at the right tempo.

I have the KP3 set up for sending clock how it's manual says, however I'm not running the latest OS on the KP3 (I'm having some trouble installing it from my PC).

Do you have any advice on getting this working? And do you think it could be related to the other controller issues with the Korg sending different/weird midi messages?

<<<<<EDIT>>>>> This was not in-fact a problem and is explained in the posts below :D

Regards,
David Smyth
NZ
Last edited by David Smyth on Tue Feb 28, 2012 3:40 am, edited 1 time in total.
Minimoog Voyager XL, Little Phatty Stage II + CV Output Mod, 2x Slim Phatty, Minitaur, MP-201, EP-2, 2x CP-251, MF-102, MF-104M, MF-107

Sir Nose
Posts: 1024
Joined: Sat Sep 20, 2008 11:15 am

Re: Dropped and stuck notes even with new firmware

Post by Sir Nose » Mon Feb 27, 2012 9:49 pm

Some time in one of the firm updates front panel control was added when in midi sync in addition to the menu clock divisions. You'll notice when using the front panel knob and in midi clock sync the rate changes are no longer smooth.

I agree that I do not like the way this functions. When changing presets i have issues that I did not before. It is also not as smooth switching between internal clock and midi clock.

I would like midi clock sync LFO rate to be set in the menu or using the clock division CC 103 and stay midi synced and at the same division when switching presets. If I touch the front panel LFO rate knob or send the LFO rate CC 3, LFO clock switches to internal automatically.

Or at least have a preset menu option for LFO clock sync internal/midi/global.

User avatar
David Smyth
Posts: 297
Joined: Tue Jun 23, 2009 3:40 am
Location: Wellington, New Zealand
Contact:

Re: Dropped and stuck notes even with new firmware

Post by David Smyth » Mon Feb 27, 2012 10:03 pm

Sir Nose wrote:Some time in one of the firm updates front panel control was added when in midi sync in addition to the menu clock divisions. You'll notice when using the front panel knob and in midi clock sync the rate changes are no longer smooth.

I agree that I do not like the way this functions. When changing presets i have issues that I did not before. It is also not as smooth switching between internal clock and midi clock.

I would like midi clock sync LFO rate to be set in the menu or using the clock division CC 103 and stay midi synced and at the same division when switching presets. If I touch the front panel LFO rate knob or send the LFO rate CC 3, LFO clock switches to internal automatically.

Or at least have a preset menu option for LFO clock sync internal/midi/global.
Thanks for the response..

Are you saying that when I change the LP Panel LFO Rate, I'm changing the clock division of the external midi tempo (not the tempo itself)?

I'll have to investigate tonight to confirm what's going on exactly.

<<<<<EDIT>>>>> After investigating using external midi clock control of the LP, it appears the modulation section's "Rate" knob does in-fact change the clock divison (eg, 1/8 notes, dotted 1/4 notes, etc.) of the midi clock signal as Sir Nose said! I found that when in the "LFO Sync" menu watching the clock division while turning the rate knob was changing the value in the menu screen. I was able to play a LFO-based lead in-time with a metronome aswell as having no problems with midi clock control over the arpeggiator. One other thing to note is that I feed the midi clock into my LP, and using the "Midi Merge" function in the global midi menu, I am able to feed that same clock to the following two SP's in my midi poly chain! All three unit's LFO's are in perfect sync! :D

So disregard my so-called problem above! :wink:


Regards,
David Smyth
NZ
Minimoog Voyager XL, Little Phatty Stage II + CV Output Mod, 2x Slim Phatty, Minitaur, MP-201, EP-2, 2x CP-251, MF-102, MF-104M, MF-107

Sir Nose
Posts: 1024
Joined: Sat Sep 20, 2008 11:15 am

Re: Dropped and stuck notes even with new firmware

Post by Sir Nose » Tue Feb 28, 2012 12:20 pm

Just another note. Midi clock is not passed along with stage 1 or tribute editions. The SP and stage 2s have a second processor for handling midi. So, they can handle the extra load. Thus, the need to update the "usb" firmware separately from the OS. For stage 1 and tributes midi is processed by the main processor. It is too busy to handle the extra load of midi clock out.

User avatar
David Smyth
Posts: 297
Joined: Tue Jun 23, 2009 3:40 am
Location: Wellington, New Zealand
Contact:

Re: Dropped and stuck notes even with new firmware

Post by David Smyth » Tue Feb 28, 2012 4:18 pm

Sir Nose wrote:Just another note. Midi clock is not passed along with stage 1 or tribute editions. The SP and stage 2s have a second processor for handling midi. So, they can handle the extra load. Thus, the need to update the "usb" firmware separately from the OS. For stage 1 and tributes midi is processed by the main processor. It is too busy to handle the extra load of midi clock out.
Interesting, I guess it's a good thing I have a LP Stage II at the start of my poly chain then! Thanks for that, and thanks for your help! :D

Regards,
David Smyth
NZ
Minimoog Voyager XL, Little Phatty Stage II + CV Output Mod, 2x Slim Phatty, Minitaur, MP-201, EP-2, 2x CP-251, MF-102, MF-104M, MF-107

vertibration
Posts: 17
Joined: Sat Feb 11, 2012 7:33 pm

Re: Dropped and stuck notes even with new firmware

Post by vertibration » Tue Feb 28, 2012 6:35 pm

So just to be clear, this Ableton Live/SLim Phatty stcuk note problem hasnt been fixed with the firmware update for me. I tried a few different set ups, and it lasts for about 5 minutes before freaking out in Ableton.

Post Reply