Moog Music Forum

Share Ideas and Pass the word

New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Everything Phatty.

New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Amos » Sat May 07, 2011 4:24 am

All updates available for download here. This is pre-release beta 3 but it is quite stable and I think just about ready for release.

First I will post the complete update packages including installer files, for updating from OS 2 or if you've never updated your Slim firmware before now.
Download links:
OS2 to 3.1 Update for Tribute Edition - [Mac OSX] - [Windows]
OS2 to 3.1 Update for Stage / Stage II Editions - [Mac OSX] - [Windows]
OS 3.1 Installer for Slim Phatty - [Mac OSX] - [Windows]

Second, if you're already running OS 3.x and you already have the PhattyLoader software, you can just download the new hex file:
TributeSystem_v3_1_653.hex
StageSystem_v3_1_653.hex
SlimSystem_v3_1_653.hex

Put the unit in Bootloader mode by powering on with MASTER button pressed/held, and confirm Firmware Update. Then open PhattyLoader software, select "File->Open..." and select the new v3_1_653 file. Click Update Firmware to send the new file to your Phatty.

New features in OS 3.1 include the following:

Glide only on legato notes option ('Legato Glide')
LFO reset on key trigger; can reset LFO phase to zero on every note or only on non-legato notes
Volume velocity sensitivity*
-- The above three options are per-preset programmable parameters added to the Advanced Preset menu.

New MIDI features:
Can now choose to filter MIDI output as follows:
- Transmit All MIDI CCs from the LP (default behavior)
- send All CCs minus Volume (CC7)
- no CCs from the knobs, only MIDI notes and pitch/mod wheel messages
- no CCs, no wheels, only MIDI notes
(All controls continue to affect the sound of the Phatty as before, only MIDI output is filtered)

Significantly improved Polyphonic note-allocation algorithm. Now does round robin note allocation with no note stealing, for lush overlapping voices.

Significantly improved incoming MIDI CC and note handling.

Arpeggiator if internal clock can now send MIDI Start, MIDI Clock, and MIDI Stop messages when running.

I am sure I am leaving out some details but those are the highlights. Please try this and let me know how you like it...

Cheers,

Amos

(* volume velocity not yet implemented on Tribute Edition. It appears that a resistor will need to be installed in the Tribute Edition before it can support volume velocity response, so it was a lower priority for this release.)
Last edited by Amos on Sat May 07, 2011 9:37 am, edited 2 times in total.
Amos
 
Posts: 2437
Joined: Wed Jul 23, 2003 3:11 pm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby kamilof » Sat May 07, 2011 7:44 am

Wow! Amos thanks a lot for all the effort and hard work! This update is awesome!!
User avatar
kamilof
 
Posts: 42
Joined: Wed May 04, 2011 7:47 am
Location: Brooklyn,NY

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby StrungbySix » Sat May 07, 2011 8:02 pm

Amos, we love you.

And moog too!
StrungbySix
 
Posts: 7
Joined: Sat Feb 26, 2011 5:51 pm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Synthetica » Sat May 07, 2011 10:09 pm

I tried to load OS 3.1 on my Little Phatty Stage II and now it is stuck with an error. I am on a Mac and tried to load with Sysex Librarian 1.22 set at 50% speed over USB. The Sysex file starts to load and then gives a Stage 1 Error Cycle Power. After turning off and back on It reads Send Firmware SX Code Error 2. I tried to then go back use Firmware 2.21 since the 3.1 won't load and gives the same results so now I'm stuck. Is there anything else I can do or have I bricked my Little Phatty. Anyone Please Help !!!
Synthetica
 
Posts: 4
Joined: Tue Apr 26, 2011 6:48 pm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Amos » Sun May 08, 2011 9:38 am

problem above is fixed... by disconnecting other MIDI cables while using USB to do the update... and setting Transmit Speed to 10% in SysEx Librarian.

Also, there may have been an issue with the hex file in the LP Stage II Mac Update. I am fixing this now.

Cheers,

Amos
Amos
 
Posts: 2437
Joined: Wed Jul 23, 2003 3:11 pm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Assar » Sun May 08, 2011 11:06 am

I have just updated my Tribute from OS2.01 to OS3.1, incl installing the bootloader.
I went flawless!
The "glide on legato" is just great, and so is the "lfo retrigger".
I love the expression possibilities they give!
It took a while to understand how the arp and the lfo work together. Actually, I am not sure I really got it yet.

Some issues with the arp:
- It always seem to start at 320 bpm (?).
- It doesn't play legato, just staccato notes. If you put it on 1/4 it plays like: 1/8 note, 1/8 pause, 1/8 note, 1/8 pause, 1/8 note, 1/8 pause ...
Am I missing something here?

Now I think I'll try the load some tuning scales too ... starting with finding out how to do that ...
:D
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Little Phatty TE #1045 | Etherwave Theremin
Stockholm, Sweden - - - Listen at: assar.se

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
User avatar
Assar
 
Posts: 359
Joined: Tue Feb 27, 2007 3:48 pm
Location: Sweden, Stockholm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby haiku-ish » Sun May 08, 2011 11:32 am

wow ! TE V2
with OS3 now !! all went well

what a great improvement ! the arp is so straight now, not sluggish anymore.

great work ! -thanks Amos.
haiku-ish
 
Posts: 128
Joined: Wed Dec 20, 2006 12:43 pm
Location: brittany

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby smokemon » Sun May 08, 2011 2:11 pm

If you have an hardwareupgraded Tribute Edition which upgrade should you go for?
#1048 LPTE
smokemon
 
Posts: 24
Joined: Wed Apr 08, 2009 12:03 pm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby joe_moog » Sun May 08, 2011 2:13 pm

Amos Gaynes for President 2012! Just sayin'...
Sub 37 • Voyager Select Whitewash/Lunar White • VX-351 • Little Phatty Stage II w/CV out • Slim Phatty (x3)
MF-101 • MF-102 • MF-104SD • MF-103 • CP-251 • MF-108M • MF-105M
Moog Pocket Protector
joe_moog
 
Posts: 113
Joined: Thu Apr 14, 2011 3:26 pm
Location: Austin, TX

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby haiku-ish » Sun May 08, 2011 2:21 pm

this one :


Amos wrote:Download links:
OS2 to 3.1 Update for Tribute Edition - [Mac OSX] - [Windows]
haiku-ish
 
Posts: 128
Joined: Wed Dec 20, 2006 12:43 pm
Location: brittany

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Assar » Sun May 08, 2011 2:30 pm

Bug (3.1T):
When I push the Master button having Tuning Scale selected (since earlier) with another tuning than #0 (for example tuning #1), the number of the used tuning is correct but the name says "Equal Temp" (the name on tuning #0).
If I switch to another tuning and back, everything is correct.
If I look at the selected tuning, press Preset, and then back to Master, everything is ok. But if I change preset in between, the wrong name of the tuning show up.
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Little Phatty TE #1045 | Etherwave Theremin
Stockholm, Sweden - - - Listen at: assar.se

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
User avatar
Assar
 
Posts: 359
Joined: Tue Feb 27, 2007 3:48 pm
Location: Sweden, Stockholm

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Kenneth » Sun May 08, 2011 7:07 pm

I loaded OS 3.1 onto my LP Stage II and am having issues with the arp as well. I can't get it above 320 bpm, which should be the highest tempo but for some reason the arp sounds really slow and it wont go faster. Is there something I'm supposed to be doing differently with the new OS?
I don't own anything that would make you jealous.
User avatar
Kenneth
 
Posts: 725
Joined: Thu Dec 04, 2008 10:41 pm
Location: Minneapolis, MN

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby EMwhite » Sun May 08, 2011 7:34 pm

Kenneth wrote:I loaded OS 3.1 onto my LP Stage II and am having issues with the arp as well. I can't get it above 320 bpm, which should be the highest tempo but for some reason the arp sounds really slow and it wont go faster. Is there something I'm supposed to be doing differently with the new OS?


Check the multiplier which dictates how many beats between notes. It can be as high as whole+whole+ and therefore appear quite slow.

This varies by preset and if you haven't had code w the Arp loaded prior, it could be set to an arbitrary value.

Let us know if that works.
'76 Minimoog, Taurus 3, Oberheim FVS + Son of 2-voice; Sequential ProOne; Juno 106; Moog Model 15; Kurzweil 250; Hammond M3; and a handful of Fender Basses Flickr!
EMwhite
 
Posts: 1638
Joined: Sun Jun 21, 2009 12:22 pm
Location: Middlesex

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Kenneth » Sun May 08, 2011 8:14 pm

Cool, I'll give that a shot as soon as I'm back home. Thanks!
I don't own anything that would make you jealous.
User avatar
Kenneth
 
Posts: 725
Joined: Thu Dec 04, 2008 10:41 pm
Location: Minneapolis, MN

Re: New Firmware v3.1 for Slim Phatty, LP Stage and Tribute

Postby Amos » Sun May 08, 2011 11:01 pm

Assar wrote:Bug (3.1T):
When I push the Master button having Tuning Scale selected (since earlier) with another tuning than #0 (for example tuning #1), the number of the used tuning is correct but the name says "Equal Temp" (the name on tuning #0).
If I switch to another tuning and back, everything is correct.
If I look at the selected tuning, press Preset, and then back to Master, everything is ok. But if I change preset in between, the wrong name of the tuning show up.


Excellent bug report, Assar! Thank you.

1) not exactly the bug you think it is. Each preset gets a "tuning number" (in advanced preset) - looks like older presets get "0" as the default tuning number per preset. When you change preset, it loads the Tuning as specified by the new preset. This is why it resets to "Equal Temp" when you change preset.

2) There are two real bugs though. One, you can change the Tuning Number in Advanced Preset, but when you save the preset, it does not save the new tuning number! I already fixed this. Second bug, the global Tuning Scale page shows the global tuning number, even when preset has loaded a different tuning. It's too confusing; I'll fix this tomorrow.

Thanks again,
Amos
Amos
 
Posts: 2437
Joined: Wed Jul 23, 2003 3:11 pm

Next

Return to Little Phatty & Slim Phatty Forum

Who is online

Users browsing this forum: CommonCrawl [Bot] and 5 guests