MF-108M malfunction: All leds are yellow

Plug in here for info tips and strategies for your Moogerfooger Analog Effects. Connect more than one for plenty of fun!
Post Reply
User avatar
Kirneh Ness
Posts: 97
Joined: Sun Dec 06, 2015 3:58 pm
Location: Denmark, Europe

MF-108M malfunction: All leds are yellow

Post by Kirneh Ness » Sun May 22, 2016 8:41 am

My cluster flux has stopped working. When I plug it on, it just lights up with all leds at constant yellow. Just happened from one day to the other. Unless it got jealous because my Minitaur got upgraded with wood panels, nothing else happened.

I have tried using my MF-104M power supply, and the result is the same. I did notice, however, when checking the MF-108M power supply on the delay pedal, that it was faulty: It required a little wriggle before the delay got turned on properly. So obviously, the power supply is not functioning as it should (cord is unstable around the jack).

But none of two well-functioning original Moog 400mA power supplies I have, make the cluster flux work. It just lights up in full yellow. :?

Does anyone have an idea what the problem can be? Can the faulty power supply have caused the problem (which I doubt, as I do not move the stuff around at all)?

I am still on warranty. In case it need to go to repairs, does one contact the seller or make an RMA with Moog (I am in Europe)? I would guess most sellers send it to Moog anyway.

Thanks in advance for any response!!
Guitars, Moog Grandmother, Minitaur, Slim Phatty, Moogerfoogers 101, 102, 103, 104M, 107, 108M and CP-251. Yamaha CS-15. Roland JUNO 106. DSI Tetr4. Arturia Beatstep Pro. Korg ARP Odyssey Module Rev1, microKORG XL.

User avatar
latigid on
Posts: 1579
Joined: Mon Jan 30, 2006 3:47 pm
Location: Auckland, New Zealand

Re: MF-108M malfunction: All leds are yellow

Post by latigid on » Mon May 23, 2016 4:04 am

Normally this isn't a good sign, there's a few known instances of MuRF pedals lighting up yellow/orange which meant something had gone awry with the CPU/MCU. Definitely look at sending it back for repair under warranty.

With luck it could be something in the power supply section caused by an intermittent power jack connection.

Good luck!

User avatar
Kirneh Ness
Posts: 97
Joined: Sun Dec 06, 2015 3:58 pm
Location: Denmark, Europe

Re: MF-108M malfunction: All leds are yellow

Post by Kirneh Ness » Mon May 23, 2016 5:45 pm

Thanks!
Guitars, Moog Grandmother, Minitaur, Slim Phatty, Moogerfoogers 101, 102, 103, 104M, 107, 108M and CP-251. Yamaha CS-15. Roland JUNO 106. DSI Tetr4. Arturia Beatstep Pro. Korg ARP Odyssey Module Rev1, microKORG XL.

Post Reply