Page 1 of 1

Sub 37 does not receive CC19?

Posted: Fri Aug 23, 2019 3:33 am
by dwetmaster
I've been trying to change the cutoff freq using MIDI but nothing seems to be working.
I'm able to use an expression pedal via Filter CV no problem. But I'm not able to change the value using cc19 like the manual says???

Re: Sub 37 does not receive CC19?

Posted: Fri Aug 23, 2019 6:55 am
by Markyboard
CC19 is the MSB (Most significant byte). Try CC51, the Filter Cutoff LSB.

Re: Sub 37 does not receive CC19?

Posted: Fri Aug 23, 2019 8:09 am
by till
CC19 (MSB) is correct.
The CC51 (LSB) range is about 1 digit of the CC19 range. So using CC51 might not cause any audible change at all.

The MSB is covering the whole range. The LSB is only the fine adjustment in between the values of one MSB digit.
So 128 times of full LSB range would be the same as the MSB range.

I don't own a Sub 37 to check your original problem here. But I am working with MIDI since MIDI became available.

Re: Sub 37 does not receive CC19?

Posted: Fri Aug 23, 2019 11:02 am
by dwetmaster
As far as I know CC19 is what I should use. My controller sends 0~127.
I can successfully use all other CCs and they do as expected, and I've confirmed that the CC19 is sent to the Sub37. But it doesn't do nothing.

Altering the Cutoff with the filter CV works fine though. I tried sending CC19 while CV filter is plugged in or not and it doesn't change anything.
Is there a setting somewhere? I've looked everywhere in the manual.

I've also been working with MIDI since 1992 :wink:

Re: Sub 37 does not receive CC19?

Posted: Fri Aug 23, 2019 3:46 pm
by Markyboard
till wrote:CC19 (MSB) is correct.
The CC51 (LSB) range is about 1 digit of the CC19 range. So using CC51 might not cause any audible change at all.

The MSB is covering the whole range. The LSB is only the fine adjustment in between the values of one MSB digit.
So 128 times of full LSB range would be the same as the MSB range.

I don't own a Sub 37 to check your original problem here. But I am working with MIDI since MIDI became available.


My mistake - you are correct. Thanks!

Posted: Sat Sep 07, 2019 10:16 pm
by HelloPutaz
:) :) :)

Re: Sub 37 does not receive CC19?

Posted: Tue Sep 10, 2019 6:11 pm
by RobustAmerican
dwetmaster wrote:
Fri Aug 23, 2019 11:02 am
As far as I know CC19 is what I should use. My controller sends 0~127.
I can successfully use all other CCs and they do as expected, and I've confirmed that the CC19 is sent to the Sub37. But it doesn't do nothing.

Altering the Cutoff with the filter CV works fine though. I tried sending CC19 while CV filter is plugged in or not and it doesn't change anything.
Is there a setting somewhere? I've looked everywhere in the manual.

I've also been working with MIDI since 1992 :wink:
I was just playing around with CCs on the Sub 37. Something that hasn't been mentioned here is the Mapping page. In the editor check the mapping page and make sure Filter Cutoff is assigned to CC19 as it should be. I've been doing the midi dance since 86/87 when I got the Roland S-50 and the MC-500. Good times.