FILTER STEPPING!!! - sub 37

Everything Sub.
Post Reply
leonnine
Posts: 5
Joined: Sat May 12, 2018 1:59 pm

FILTER STEPPING!!! - sub 37

Post by leonnine » Sat May 12, 2018 3:15 pm

Ive noticed some filer stepping when sweeping filter knob extremely slowly with res fully up on my sub 37. :(
I then routed it to mod wheel to see if that was any better but it still seems to be there.

I took everything out of mixer so you only hear the filter cutoff. I uploaded a demo of it on soundcloud:

https://soundcloud.com/leonnine/moog-su ... r-stepping


it seems to step in semitones rather than random places.
In comparison i tested it on my slim phatty and it was totally smooth.

gone back a fourth a few times and they're defiantly different filter designs or are implemented differently.

could this be why they sound different ( phatty - smoother, fuller, rounder / subs - raspy, edgy, )

any one else tried this on their sub 37 or on a subsequent 37?
there were some changes to the filter i think.

DrJustice
Posts: 183
Joined: Mon Sep 28, 2015 4:28 pm

Re: FILTER STEPPING!!! - sub 37

Post by DrJustice » Sat May 12, 2018 4:26 pm

Can't say I've gotten quite what you have there. If there's some signal being fed to the filter you can get harmonic stepping, but since you have switched of all sources in the mixer it can't be that. If you post a patch with this phenomenon, I'll test it on my Sub 37.

leonnine
Posts: 5
Joined: Sat May 12, 2018 1:59 pm

Re: FILTER STEPPING!!! - sub 37

Post by leonnine » Sat May 12, 2018 5:24 pm

i just loaded a init patch and turned mixer signals off, turned res to full and moved cut off very slowly.

Like a mm per second. hardly moving it.

anything faster doesn't seem noticeable.

I might not have thought much about it if the slim phatty did the same, but it doesn't.

DrJustice
Posts: 183
Joined: Mon Sep 28, 2015 4:28 pm

Re: FILTER STEPPING!!! - sub 37

Post by DrJustice » Sat May 12, 2018 10:45 pm

OK, tested, and I get the semitone stepping on extremely slow movements of the cutoff knob, as you do. When the cutoff knob is being moved a little faster it's totally smooth. The mod wheel seems to work fine though (using CONST ON for MOD 1 with 100% MW control), not stepping even if I move it much slower than the cutoff knob.

I don't normally sweep the filter that slowly, so I haven't picked this up before. However, when I think about it, this explains why it's hard to do the iterative fine tuning of the oscillating filter for precise 1:1 tracking - turns out I have experienced the stepping doing just that.

Seems like a bug then (using firmware 1.2.0 here). Since Moog is stonewalling us on the forum (they used to participate a year or two ago, commenting on bugs and the like), I guess opening a tech support ticket is the only way to find out more.

leonnine
Posts: 5
Joined: Sat May 12, 2018 1:59 pm

Re: FILTER STEPPING!!! - sub 37

Post by leonnine » Sun May 13, 2018 8:31 am

yeah, i might do that to find out more.

I wondered if they did it to help tune the filter to key notes as it steps in semitones.

with a tuner, ive had more success tuning the filter to notes by getting close with cut off and fine tuning it with the KB track amount knob.
On my dial it sits just below 1:1 for perfect pitch. though it may be different every time i try with the nature of analogue.
Then the stepping does make sense to hold it to each note when it gets close enough.

Id like to find out if it doesn't step on faster movements (rather than not being able to tell) then that would be quite clever implementation for filter design to cater for both needs.

The fact that its not the same as my slim phatty means they did something different to it.
whether its intensional or not.

I had a little search online before posting and didn't find anything about it.

Its definitely better assigned to mod wheel but i still got it to step a bit with some movement between the steps unlike the cutoff knob.

Id like to hear from subsequent 37 users too, as they made some subtle changes to filter design.

DrJustice
Posts: 183
Joined: Mon Sep 28, 2015 4:28 pm

Re: FILTER STEPPING!!! - sub 37

Post by DrJustice » Sun May 13, 2018 8:58 am

I tried some more today, with fresh ears. It seems to go from stepped to completely smooth at a specific sweep speed. I still can't get the mod wheel to step. I also tried super slow envelope sweeps, and that's perfectly smooth.

The fact that it steps at semi tone intervals supports your suggestion that it might be a feature. However, it doesn't land on the same semitone steps as the oscillators by default, and the fine tune knob only tunes the oscillators, not the filter. I.e. I find it a hindrance for precise tuning rather than a help - ref. the 1:1 tuning, also discussed in the Playing filter resonance (Sub 37)-thread (where I mention the tendency for the filter to "stick"). Also, it would've been a super obscure and 'secret' feature, so I'm not sure. In any case, I'd prefer that it was non stepped.

I'd think that the Subsequents use the same code base and would exhibit the same behaviour. If you hear anything from tech support please let us know.

haternob
Posts: 1
Joined: Wed May 23, 2018 7:36 am

Re: FILTER STEPPING!!! - sub 37

Post by haternob » Wed May 23, 2018 7:39 am

I have a Subsequent 37 CV with the latest OS installed and it behaves in the same way. It doesn't really pose an issue for me personally but I'm still looking forward to hearing what Moog Support have to say about this.

Post Reply