Page 1 of 1

Blank Display Screen (Sub37 Tribute Edition)

Posted: Thu Jan 04, 2018 10:35 pm
by Chimponaut
Howdy,

Turned on my Sub 37 Tribute Edition the other day, just like every other day since I got it (Aug 2016) and the display lights up but no text is displayed. Just a bright, light blue screen. Everything else is working properly though. Sounds load and play perfectly and the editor still controls it flawlessly. Front panel buttons still function etc...I tried the Contrast Slider in the editor but it has no effect.

I've searched the forum but it seems most people that experienced this also had other functionality problems along with the blank display. I submitted a support ticket but was just wondering, while I'm waiting to hear from them, if anyone else has had this same problem...With just the display going blank. It has been colder here lately so I wonder if that could have anything to do with it.

Thanks for any info!

Re: Blank Display Screen (Sub37 Tribute Edition)

Posted: Thu Feb 01, 2018 7:56 pm
by RAmdahl
Hi, can you please post an update, when Moog get back to you? I got this problem after updating the firmware to 1.2.0.

Re: Blank Display Screen (Sub37 Tribute Edition)

Posted: Fri Feb 02, 2018 3:44 am
by Chimponaut
RAmdahl wrote:Hi, can you please post an update, when Moog get back to you? I got this problem after updating the firmware to 1.2.0.


My issue isn't related to the firmware version or a failed firmware update. My unit was functioning perfectly and the LCD just went blank out of nowhere. The synth is still functioning perfectly and I'm using the Software Editor to see and change the settings. I've purchased a new LCD screen from Moog but upon installation a different piece of the LCD assembly broke and became a problem. (the ribbon header) Ordered a replacement for the ribbon header piece but it arrived already broken from transit. Not only that, during this last attempt I noticed that a piece of the original broken header is stuck in the slot it slides into to hold the LCD ribbon in place. I tried for 2 hours to get the piece out but couldn't manage it. At this point I've taken the synth apart twice to install the new LCD but both times the ribbon header has been a problem. This is a very small piece of plastic that serves to hold the LCD ribbon cable in place and I'm starting to think that my original LCD screen was fine and that this header piece was the problem all along. This LCD ribbon header is very small and obviously quite fragile. Now I either have to send the whole synth into Moog or hopefully just the board that is involved.