Page 2 of 2

Re: Sub 37 Editor problems

Posted: Thu Mar 08, 2018 8:32 pm
by jupiter
They are identical. The VSTi can have its GUI automatically adjusted when sending program changes to the hardware from within a DAW. AFAIK that's the only difference.

Re: Sub 37 Editor problems

Posted: Sun Mar 11, 2018 8:50 am
by redlester
jupiter wrote:They are identical. The VSTi can have its GUI automatically adjusted when sending program changes to the hardware from within a DAW. AFAIK that's the only difference.


Cheers, I guessed something like that but always nice to have confirmation.

Re: Sub 37 Editor problems

Posted: Sun Mar 11, 2018 8:56 pm
by papawise
I've contacted Moog by email 7 days ago, and still no answer.

Re: Sub 37 Editor problems

Posted: Wed Mar 14, 2018 6:46 am
by papawise
I spent all night reinstalling all my system, migrated to Windows 10 Pro, I have everything working as intended now and like it must be, with MIDI only thru USB.

Because I'm not a moron, I came back to update, because I really complained about the editors, and the "disconnected" issue, but I also must say that I never got support from Moog by email nor in this forum. The thing just doesn't work in Windows 7 if you have a modern PC (z270 / z370).

Anyways, everything working now on Windows 10 Pro + Ableton Live 10 (USB driver 4.35.0 + Firmware 1.2.0 + Editor 1.0)

Best.

Re: Sub 37 Editor problems

Posted: Wed Mar 14, 2018 1:41 pm
by jupiter
It sounds as if you had reminiscents of older drivers in your System32\drivers folder, clashing with the new ones. When you move on to the newer 2.23.0 (for Sub 37) in Windows 7, you should really remove the generic moog driver and files. Note that for minitaur, the correct driver for Windows 7 (and up) is 4.35.0.

Re: Sub 37 Editor problems

Posted: Thu Mar 15, 2018 4:49 am
by papawise
maybe, maybe not,
I've tried different configurations dozen of times with clean Windows 7 installs and with several downgrades and/or upgrades of firmware/USB driver versions. In many cases I scanned the windows registry cleaning entries so... I don't know
but the thing doesn't work right out of the box as with Windows 10.

Re: Sub 37 Editor problems

Posted: Mon Mar 19, 2018 10:33 pm
by sub guy
Wow sounds like a few problems with the editor. I just received a link from Moog for the editor and an updated version of firmware for my Sub 37.

Before I install the new firmware I would like to make sure I dont already have it. How do I check which version I already have?

Re: Sub 37 Editor problems

Posted: Tue Mar 20, 2018 4:00 am
by kouik
Hi Sub Guy,

from the synth, global button, on the third page you'll have an entry for this.

Another way, start the upgrader with the sub connected by USB, it will show the current version, and the one to be updated.

Regards.

Re: Sub 37 Editor problems

Posted: Tue Mar 20, 2018 11:22 pm
by sub guy
kouik wrote:Hi Sub Guy,

from the synth, global button, on the third page you'll have an entry for this.

Another way, start the upgrader with the sub connected by USB, it will show the current version, and the one to be updated.

Regards.


Thanks for the reply.