Moog Sub 37 Panel Mode

Everything Sub.
Post Reply
voyager0500
Posts: 52
Joined: Fri Nov 10, 2006 4:56 am
Location: London
Contact:

Moog Sub 37 Panel Mode

Post by voyager0500 » Fri Jun 17, 2016 6:28 am

Hi guys

Wondering about the Panel Mode on the Sub 37. Ive noticed that the panel mode doesnt save all changes that I make on the front after powering up and going back into panel mode? This is especially true for the mod bus, pitch bend values and arp settings. Am I missing something?

On the Voyager after turning it back on, the sound/setting you had before is EXACTLY how it was when you turn it off. I am guessing the Panel Mode is supposed to be like that?
'i used to be a plastic cup..'
-remarkable-

User avatar
stiiiiiiive
Posts: 2239
Joined: Tue Aug 30, 2011 2:58 pm
Contact:

Re: Moog Sub 37 Panel Mode

Post by stiiiiiiive » Fri Jun 17, 2016 7:53 am

Panel mode is expected to reflect exactly what the panel looks like, i.e. every knob setting. If you move the knobs between the moment you get in Panel Mode and the moment you... get back to it, it's normal the sound is different.

voyager0500
Posts: 52
Joined: Fri Nov 10, 2006 4:56 am
Location: London
Contact:

Re: Moog Sub 37 Panel Mode

Post by voyager0500 » Fri Jun 17, 2016 10:24 am

Hey stiiiiiiive

That of course makes sense but its not whats happening.

Im in Panel mode and make my changes, set the modulation values in controllers for MOD1/MOD2, set the Pitch bend values (-12 down, +5 up), so far so good and everything is working ok. Now im done with playing, switch off the synth and go do something else. Now when i turn it back on (without moving any knobs whilst it was off) it defaults to Preset Mode. I switch it back to Panel mode and my previous values are not stored anymore, namely the pitch bend value and the mod section controls..
'i used to be a plastic cup..'
-remarkable-

User avatar
stiiiiiiive
Posts: 2239
Joined: Tue Aug 30, 2011 2:58 pm
Contact:

Re: Moog Sub 37 Panel Mode

Post by stiiiiiiive » Fri Jun 17, 2016 3:17 pm

I understand better: these are not proper panel parameters but rather soft parameters, right?
I guess the panel mode takes the values the former preset has, or maybe there is some sort of default panel parameter set.

Actually I don't have any Sub37, I'm just trying here :D

Anybody?

DrJustice
Posts: 181
Joined: Mon Sep 28, 2015 4:28 pm

Re: Moog Sub 37 Panel Mode

Post by DrJustice » Sun Jun 19, 2016 9:17 am

Looks like panel mode sets the mod menu parameters to defaults, as for an init patch.

mikeh11
Posts: 213
Joined: Mon Dec 28, 2015 6:40 pm

Re: Moog Sub 37 Panel Mode

Post by mikeh11 » Sun Jun 19, 2016 8:08 pm

The Sub 37 manual on page 14 says:
In PANEL mode, the sound you hear reflects the current position of the front-panel knobs and buttons. Parameters in this mode (other than the knobs) are saved in a special buffer, so you can pre-set the panel to retain any non-knob settings you choose.

I started writing a note saying that maybe you found a bug, because in my attempts to recreate the problem, I also thought that the pitch-bend was "lost" in a power down. In duplicating my steps, I find that it works as advertised. Hmmm.

This is with FW 1.2.0.
Went to panel mode.
Set Mod2 triangle wave to mod the filter.
Set the Mod2 depth controls - mod wheel, aftertouch, velocity.
Set LFO2 keytrack to 100%.
Got into the Preset Edit menu, and set pitch-bend up/down to "way big"™.
Exited Preset Edit menu.
Verified everything was there in panel mode.
Switched to preset mode, selected several presets.
Went back to panel mode, everything was still set as before.
Back to preset mode.
Powered off, waited a bit, powered on.
Back in panel mode, everything was still set, even pitch-bend.

Also powered-off when in Panel mode, and it was still OK when I came back.
What firmware is your Sub37 running?
MBP 2012 | OS X 10.11.6 | Sub 37 #6768

voyager0500
Posts: 52
Joined: Fri Nov 10, 2006 4:56 am
Location: London
Contact:

Re: Moog Sub 37 Panel Mode

Post by voyager0500 » Mon Jun 20, 2016 7:52 am

Thanks mikeh11

Ill try this exact sequence when I am next with my Sub 37. I am running the 1.2.0 FW BTW.

Anyone else care to give the below a try to ascertain if it works in the meantime?

@mikeh11 try doing an innit patch on the panel mode and change the pitch wheel bend ammounts and control ammounts and switch off the synth without going into preset mode and see if that works


mikeh11 wrote:The Sub 37 manual on page 14 says:
In PANEL mode, the sound you hear reflects the current position of the front-panel knobs and buttons. Parameters in this mode (other than the knobs) are saved in a special buffer, so you can pre-set the panel to retain any non-knob settings you choose.

I started writing a note saying that maybe you found a bug, because in my attempts to recreate the problem, I also thought that the pitch-bend was "lost" in a power down. In duplicating my steps, I find that it works as advertised. Hmmm.

This is with FW 1.2.0.
Went to panel mode.
Set Mod2 triangle wave to mod the filter.
Set the Mod2 depth controls - mod wheel, aftertouch, velocity.
Set LFO2 keytrack to 100%.
Got into the Preset Edit menu, and set pitch-bend up/down to "way big"™.
Exited Preset Edit menu.
Verified everything was there in panel mode.
Switched to preset mode, selected several presets.
Went back to panel mode, everything was still set as before.
Back to preset mode.
Powered off, waited a bit, powered on.
Back in panel mode, everything was still set, even pitch-bend.

Also powered-off when in Panel mode, and it was still OK when I came back.
What firmware is your Sub37 running?
'i used to be a plastic cup..'
-remarkable-

DrJustice
Posts: 181
Joined: Mon Sep 28, 2015 4:28 pm

Re: Moog Sub 37 Panel Mode

Post by DrJustice » Mon Jun 20, 2016 10:44 am

I can confirm mikeh11's findings!

Also, If you hold the panel button down while in panel mode, the MOD menus parameters gets initialized (I don't think it touches the PRESET menu parameters, since PANEL and PRESET are mutually exclusive otherwise.

I did make a strange observation though: when I first went into panel mode to test this, all the controller values for MOD 1 and 2 was set to 97%. I've never made those settings, so that could be from some buggy'ish initial values(?) Running FW 1.2.0.

User avatar
bichuelo
Posts: 797
Joined: Fri Jan 22, 2010 5:25 pm
Location: Bogotá, Colombia
Contact:

Re: Moog Sub 37 Panel Mode

Post by bichuelo » Wed Jun 22, 2016 5:26 pm

mikeh11 wrote:The Sub 37 manual on page 14 says:
In PANEL mode, the sound you hear reflects the current position of the front-panel knobs and buttons. Parameters in this mode (other than the knobs) are saved in a special buffer, so you can pre-set the panel to retain any non-knob settings you choose.

I started writing a note saying that maybe you found a bug, because in my attempts to recreate the problem, I also thought that the pitch-bend was "lost" in a power down. In duplicating my steps, I find that it works as advertised. Hmmm.

This is with FW 1.2.0.
Went to panel mode.
Set Mod2 triangle wave to mod the filter.
Set the Mod2 depth controls - mod wheel, aftertouch, velocity.
Set LFO2 keytrack to 100%.
Got into the Preset Edit menu, and set pitch-bend up/down to "way big"™.
Exited Preset Edit menu.
Verified everything was there in panel mode.
Switched to preset mode, selected several presets.
Went back to panel mode, everything was still set as before.
Back to preset mode.
Powered off, waited a bit, powered on.
Back in panel mode, everything was still set, even pitch-bend.

Also powered-off when in Panel mode, and it was still OK when I came back.
What firmware is your Sub37 running?


I tried this and it works fine.

@voyager0500 can you do a thorough test with a list like this one to see if someone else can reproduce your problem? I tried what you told on June 20 and it works perfectly as well
http://audiotecna.info
T-III, Voyager, VX-351, Slim Phatty, Model D, Sub Phatty, Subsequent 37, Minitaur, all moogerfoogers and minifoogers, EW+, Theremini, Model 15, Filtatron, Animoog, Model D App, iOS 11 Mother-32, DFAM, Werkstatt, Win7, High Sierra

mikeh11
Posts: 213
Joined: Mon Dec 28, 2015 6:40 pm

Re: Moog Sub 37 Panel Mode

Post by mikeh11 » Thu Jun 23, 2016 11:55 am

@mikeh11 try doing an innit patch on the panel mode and change the pitch wheel bend ammounts and control ammounts and switch off the synth without going into preset mode and see if that works

test1
- init preset (press and hold Panel button)
- mod2 control button
- changed mod/press/velo control amts
- preset edit (press and hold Preset button)
- changed pb depths
- immediate power off
- wait 1 min
- power on
- press Panel button
- all settings still there
- still good the next day, too! :-)

Seems OK?
MBP 2012 | OS X 10.11.6 | Sub 37 #6768

Post Reply