Problems with Sysex Librarian and Sub 37 banks

Everything Sub.
Post Reply
mikeh11
Posts: 213
Joined: Mon Dec 28, 2015 6:40 pm

Problems with Sysex Librarian and Sub 37 banks

Post by mikeh11 » Tue Mar 22, 2016 8:02 pm

Problems using Sysex Librarian to backup a single Sub 37 bank; I'm on OSX 10.11.3.

I was playing around with Sysex Librarian and the Sub 37.

I told Sysex Librarian to Record Many. Then, one by one, I sent a Current Preset dump from the Sub 37, selecting each preset within Bank 1. I stopped Sysex Librarian, and saved the file as Bank01.syx. I verified the contents of the syx file - it looks good, complete, correct size, correct messages.

Then, I copied a few Bank 1 presets to neighboring slots, just to scramble the presets in that bank a little bit.

Then, I sent the Bank01.syx file from Sysex Librarian to the Sub 37.

The duplicate presets were still there.

I tried a 250ms, 512ms, and 1 second delay between the messages. Same thing. The Transmit Speed is set to 50% (left over from a firmware update).

MIDI Monitor shows the presets being sent - each one a "preset" dump (not an edit buffer), with different slot numbers, with a delay between them.

In the last test, it seems like maybe the incoming messages always wrote to Bank 1 Preset 1, since it was left containing '1974th' (which came from Bank 1 Slot 16). But I can see that the messages are "preset dump"s and each goes into a different slot (judging by bytes 6 and 7 in the message).

I'm wondering what I did wrong, or what I missed, or what I misunderstand.
Any clues anyone?
Thanks!
MBP 2012 | OS X 10.11.6 | Sub 37 #6768

ObtuseMoose
Posts: 68
Joined: Sun May 24, 2015 7:36 pm

Re: Problems with Sysex Librarian and Sub 37 banks

Post by ObtuseMoose » Wed Mar 23, 2016 10:22 am

mikeh11 wrote:...
In the last test, it seems like maybe the incoming messages always wrote to Bank 1 Preset 1, since it was left containing '1974th' (which came from Bank 1 Slot 16).
...


Yep. Presets saved with the CURRENT PRESET sysex dump will always be loaded into whatever preset slot is current when they are loaded, not the slot they were saved from. See the top of page 38 in the manual.

You can save individual presets with the CURRENT PRESET dump, but you must save them as separate files. Or you can save all presets from all banks with the ALL PRESETS dump. As far as I know, it's not possible to save and load a single bank of presets from the Sub37. (Might be possible with the editor, but I've not tried the editor beta.)

--
Moose

mikeh11
Posts: 213
Joined: Mon Dec 28, 2015 6:40 pm

Re: Problems with Sysex Librarian and Sub 37 banks

Post by mikeh11 » Thu Mar 24, 2016 8:04 pm

Thanks, 'Moose! I read that page lots of times, but I guess I saw only what I wanted to see.

Grrr. Well, gee. That's really, REALLY, disappointing. Why bother putting the preset number inside the sysex dump, if it never gets used? :? (never mind; rhetorical question)

So, we can save the edit buffer, which doesn't know where it came from or where to go to.
We can save the current preset, which knows where it came from, but that gets ignored when loaded.
We can save all the presets (in one big file), and they all go back to where they came from.
Seems like a certain option is missing?

Thanks, again!
MBP 2012 | OS X 10.11.6 | Sub 37 #6768

User avatar
fwilleke
Posts: 105
Joined: Tue Oct 14, 2014 4:24 am
Location: Berlin, Germany
Contact:

Re: Problems with Sysex Librarian and Sub 37 banks

Post by fwilleke » Fri Mar 25, 2016 6:41 am

Wait for the Sub 37 Editor software, which should come out soon.
It'll solve all these problems.
___
Sub 37 Cookbook
My Website
Gear List
Me on Instagram

15" late 2013 MacBook Pro
Mac OS X El Capitan 10.11.3

Post Reply