Sub 37 Arp Synch to Pro Tools 11 DAW

Everything Sub.
Post Reply
mmidden
Posts: 7
Joined: Fri Aug 29, 2014 10:12 pm

Sub 37 Arp Synch to Pro Tools 11 DAW

Post by mmidden » Sat Nov 29, 2014 7:30 pm

Sorry everyone if this is a gratuitous post but I see a lot of similar posts but none which seem to address the issue I'm having synching my sub 37 arpeggiator as a midi controller in pro tools.
For some reason when I enable the arpeggiator synch button on my Sub 37 and start pressing keys Pro Tools doesn't seem to recognize it and the virtual instrument I'm trying to control doesn't play anything back. If I turn off the synch button and start playing a sequence from the arpeggiator PT recognizes and plays back the notes but if I hit synch after I start playing back the arp it doesn't seem to be able to synch up to the PT tempo.

Again, apologies if this is a redundant question. I've been playing around and searching for the answer for a couple of days now. Hopefully I've provided enough info to describe the problem.

Also, if it makes a difference I have the most recent firmware update 1.0.6

klfnk
Posts: 44
Joined: Sun Sep 28, 2014 6:52 am

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by klfnk » Sun Nov 30, 2014 11:23 am

If I remember correctly you can change a setting in the sub 37 menu (not behind it now).
This allows the 37 to sent either arp or seq midi notes to midi out.
Check you manual or dive into the menu.

Cheers
Moog Sub 37
Ableton Live 8.latest
Pro Tools 12 HD12.latest
RME Fireface UC
15" MacBook Pro Retina 2015 Yosemite

mmidden
Posts: 7
Joined: Fri Aug 29, 2014 10:12 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by mmidden » Sun Nov 30, 2014 7:00 pm

Yeah, I have this setting Global Menu > Clock Options > Send Clock > ARP but no luck still. I've tried a number of various tweeks within the Midi and Global and Preset menus on the Sub 37 and several combinations of settings within Pro Tools but still can't quite get it to work.

If anyone else has any suggestions I'd love to hear from you.

BorisYeltsin
Posts: 33
Joined: Sun Nov 09, 2014 6:23 am

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by BorisYeltsin » Mon Dec 01, 2014 2:14 am

Maybe sync DAW with external MIDI-gear? In cubase this is done by pressing ctrl + mouseclick on SYNC and then:

Midi clock follows project position: Yes/check
Always send start message: Yes/check
Send midi clock in stop mode: Yes/check

Read more here: http://forum.moogmusic.com/viewtopic.php?f=7&t=22533

Don't know about Pro Tools though.

If you press PLAY in Pro Tools, after pressing SYNC on 37, does it work?

User avatar
_DemonDan_
Posts: 1267
Joined: Mon Nov 16, 2009 4:52 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by _DemonDan_ » Mon Dec 01, 2014 10:25 am

mmidden wrote:...when I enable the Arpeggiator's Sync button on my Sub 37 and start pressing keys Pro Tools doesn't seem to recognize it and the virtual instrument I'm trying to control doesn't play anything back. If I turn off the Sync button and start playing a sequence from the arpeggiator PT recognizes and plays back the notes but if I hit Sync after I start playing back the arp it doesn't seem to be able to synch up to the PT tempo.
klfnk wrote:If I remember correctly you can change a setting in the Sub 37 menu (not behind it now).
This allows the 37 to sent either Arp or Seq MIDI notes to MIDI out. Check your manual or dive into the menu.
Hi mmidden,
klfnk is right. The button you're looking for is called MIDI OUT in the SEQUENCER OPTIONS sub menu, which is found in the GLOBAL menu.

The two choices are: SEQ and KEYS. I believe KEYS will do what you want.
_ :twisted: _DemonDan_ :twisted: _

mmidden
Posts: 7
Joined: Fri Aug 29, 2014 10:12 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by mmidden » Wed Dec 03, 2014 11:44 pm

Hey guys, thanks for the helpful suggestions. I had actually tried various combinations of those different settings on my Sub 37 but the problem turned out to be a setting within Pro Tools. I often share files back and forth with a good buddy of mine and somewhere along the line some of his default settings got pushed to my Pro Tools system.

The problem turned out to be that I need to turn off delay compensation under the Preferences > MIDI > Delay Compensation for External Devices.

mmidden
Posts: 7
Joined: Fri Aug 29, 2014 10:12 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by mmidden » Sun Dec 07, 2014 2:00 pm

Ack! Looks like I may have spoke too soon. When I opened up a session I was working in last night and connected my Sub 37 I couldn't get it to synch up with PT's tempo properly. It's almost never right on the beat, sometimes kind of close and other times the midi note is bisected by the beat grid.

Again, I've tried various combinations of settings in PT and on the Sub 37 with no luck. Delay Compensation on or off doesn't seem to do the trick. Sequencer Options set to KEYS doesn't work because then the Sub 37 Arpeggiator doesn't function.

At this point I can't even figure out which environment needs a settings adjustment. I'll keep playing around but if anyone has any suggestions I'd love to hear to them again. Funny thing is I've definitely had this working a few times but for some reason it doesn't seem to be consistent.

rgcoleman9
Posts: 1
Joined: Sun Mar 13, 2016 6:42 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by rgcoleman9 » Tue Mar 15, 2016 5:12 pm

I am a new Sub 37 owner (and new forum member), so instead of starting a new topic, I thought I'd resurrect this one as I am having similar issues in Pro Tools 10. Sometimes it works, sometimes it doesn't. At first I thought it was because of trying to run two USB MIDI inputs, but removing one doesn't permanently solve the problem. Any help with this would be much appreciated!

clarkswift
Posts: 1
Joined: Sun Jan 08, 2017 3:00 pm

Re: Sub 37 Arp Synch to Pro Tools 11 DAW

Post by clarkswift » Sun Jan 08, 2017 3:46 pm

I have it working on my PT 12.6 rig right now. The sync was always off for me and it was really frustrating but fiddling around with the OFFSET in the MIDI BEAT CLOCK window allowed me to sync down to the very sample. Follow these set of parameters below and maybe you will be able to get the same results. Feel free to skip everything past the MIDI menu in the SUB 37 parameters. I have my global settings defaulted but I know sometimes things get turned around.


IN PRO TOOLS
set up these parameters

Setup > MIDI > MIDI Beat Clock
1. Enable MIDI BEAT CLOCK for SUB 37
2. Offset Sub 37 by -3147 Samples

Preferences > MIDI

Uncheck all boxes under the DELAY COMPENSATION FOR EXTERNAL DEVICES

IN SUB 37 set up these parameters

SYNC must be enabled. ARPEGGIATOR must be enabled.

MIDI

1. IN CHANNEL = 1
2. OUT CHANNEL = 2
3. SEND PGM CHG = ON
4. RCV PGM CHG = ON
page 2
5. IN PORTS = USB
6. OUT PORTS = USB
7. ECHO DIN IN = OFF
8. ECHO USB IN = OFF
page 3
9. POLY NUMBER = 1 (I only have 1 external device)
10. POLY MAX = 1

OUTFILTERS >>
1. KEYS = ON
2. WHEELS = ON
3. PANEL = ON
4. KNB NRPN/CC = CC
5. CC FORMAT = 7-BIT
(BACK)<<

CLOCK OPTIONS >>
1. SEND CLOCK = OFF
2. SEND ST/STP = ON
3. FOLLOW SPP = ON
(BACK)<<

SYSEX>>
ALL SEND

GLOBAL

CV MAPPING >>
1. PITCH = DEFAULT
2. VOLUME = DEFAULT
3. GATE = DEFUALT
4. GATE INVERT OFF
5. PER PRESET = OFF

SEQ OPTIONS >>
1. REF NOTE = FIRST
2. PHASE RESET = OFF
3. LATCH RSTRT = ON
4. DLAY PGM CHG = OFF
5. MIDI OUTPUT = KEYS

SEQ PG CHASE = ON
FINE TUNE = EDIT
PRESET MWHL = ON

Default from there on out.

Hopefully this helps!

Post Reply