Need Sub Phatty editor and firmware update any news?

Everything Sub.
Flux302
Posts: 9
Joined: Wed May 21, 2014 8:46 pm

Need Sub Phatty editor and firmware update any news?

Post by Flux302 » Wed Sep 24, 2014 4:23 pm

Really hoping to hear any sort of timeline on an update to fix the Sub Phatty's editor from constantly having disconnect issues and also a firmware update to bring it more inline with the Sub37 (this is more wishful thinking) ...

with Moog's reputation for high quality... having a software editor that constantly disconnects is kinda :oops:
if you guys need a beta tester (which I guess I already am seeing as the last update I got was a beta that was hoped to fix this issue) ... please let me know. I am very well versed in bug tracking , trouble shooting etc.

Thanks

Flux
Fluxwithit.com

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Tue Oct 07, 2014 6:03 pm

Hi, here is a new firmware update for Sub Phatty. This should have more reliable USB MIDI with no disconnections.
http://www.moogconnect.net/downloads/su ... _2_0_6.zip

Sorry for the trouble! If any further issues, let me know.

Oh and if you are using Windows you might try this USB MIDI driver... it supports Sub Phatty, Minitaur and Sub 37 and provides multi-client USB MIDI support, which means that more than one software app can talk to the USB MIDI ports at the same time.

http://www.moogconnect.net/downloads/Mo ... 2.23.0.zip

all the best,

Amos

User avatar
Meneer Vincent
Posts: 43
Joined: Fri Jul 18, 2014 7:27 am
Location: Netherlands - Rotterdam

Re: Need Sub Phatty editor and firmware update any news?

Post by Meneer Vincent » Wed Oct 08, 2014 5:09 am

Thanks Amos,

Sorry for this question but how can I proper install the update without troubles.
Directly in the SubPhatty editor (is there a link) or are there other steps to make?

User avatar
Meneer Vincent
Posts: 43
Joined: Fri Jul 18, 2014 7:27 am
Location: Netherlands - Rotterdam

Re: Need Sub Phatty editor and firmware update any news?

Post by Meneer Vincent » Wed Oct 08, 2014 6:59 am

Sorry Amos I see there is a instruction sheet now.
We give it a try!

Thanks!

Rokatansky
Posts: 36
Joined: Thu May 23, 2013 4:43 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Rokatansky » Wed Oct 08, 2014 6:10 pm

Is this safe to install?
I was beta tester and in one update my Sub got freeze and required to send back to service.I don't want that trouble again.

Thanks

User avatar
Meneer Vincent
Posts: 43
Joined: Fri Jul 18, 2014 7:27 am
Location: Netherlands - Rotterdam

Re: Need Sub Phatty editor and firmware update any news?

Post by Meneer Vincent » Thu Oct 09, 2014 9:02 am

@Rokatansky I just completed the update. Read the instructions step by step and it's working succesfully.
Thanks @Amos!

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Thu Oct 09, 2014 10:04 am

Rokatansky wrote:Is this safe to install?
I was beta tester and in one update my Sub got freeze and required to send back to service.I don't want that trouble again.

Thanks


Yes it's safe. The problem you had before was very specific to that particular beta test; it involved a problem with updating the bootloader. We are not updating the bootloader this time; just the main firmware. (that's why it's safe; because there is a bootloader that remains in place to allow for repeated firmware updates)

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Thu Oct 09, 2014 1:40 pm

Hi.
so here it goes.
- installed new firmware
- then checked via standalone editor: yes, running v2.0.6.
- installed the new USB MIDI driver
- then checked via standalone editor: no. "hardware disconnected".
- restarted both computer and Sub Phatty
- checked again via standalone editor: nope. hardware disconnected.
- checked via VSTi: same. disconnected.
- uninstalled the new USB MIDI driver, and restarted moog.
- basic usb driver was successfully re-installed.
- checked via standalone editor: connected.
- checked via VSTi: no. hardware disconnected.

So, the new USB midi driver didn't do me any good at all,
because now it is even worse than before (the VSTi used to work up until this point).

System, same as before:
Win7 64-bit, running editor v1.1.0 and 64-bit VI.

Rokatansky
Posts: 36
Joined: Thu May 23, 2013 4:43 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Rokatansky » Thu Oct 09, 2014 2:14 pm

Amos & Meneer Vincent
Thanks for the info.
Gonna update now.

Kind Regards

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Fri Oct 10, 2014 4:16 am

anyone else experienced something similar to what I described? ^

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Tue Oct 14, 2014 3:23 pm

hm, I guess no.
Amos - any thoughts?
Don't mean to be unpatient here, but I've waited for a solution for 16 months now.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Tue Oct 14, 2014 5:31 pm

Denim wrote:hm, I guess no.
Amos - any thoughts?
Don't mean to be unpatient here, but I've waited for a solution for 16 months now.


I cannot account for your results. I too am using Windows 7 64-bit (professional, SP1 if it makes a difference).
I am using the Moog USB MIDI driver with the Sub Phatty and it's working fine.
I can use the standalone Sub Phatty Editor and it's working fine; I can use the Sub Phatty Editor plugin and it's working, no "disconnected" message.

I just realized the plugin editor i'm using is v1.0.3... I'll test v1.1 again... it's working for me also. Tested in Cubase v7.5 and Live 9.0.6.

I don't know if I'm somehow failing to see something obvious that you aren't doing... I assume you can see and select the Sub Phatty as the MIDI in/out device in the Editor... are you seeing "Hardware disconnected" instead of the firmware version, in the lower left corner of the Preferences page, or are you seeing it somewhere else?

Zap_pa
Posts: 5
Joined: Wed Oct 15, 2014 5:30 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Zap_pa » Wed Oct 15, 2014 5:49 am

@ Denim,

Do you have a USB Generic Parent Driver (Usbccgp.sys) installed on your computer?

(Device Manager - Universal Serial Bus controllers - USB Composite Device)

Denim
Posts: 35
Joined: Thu Aug 08, 2013 10:38 am

Re: Need Sub Phatty editor and firmware update any news?

Post by Denim » Thu Oct 16, 2014 9:08 am

@ Zap_pa:
Yes, the file USB Generic Parent Driver Usbccgp.sys is intalled on my system. Is that good or bad in this case?

@ Amos:
Yes I aso have SP1. But here is a little update on the issue:
- after some more testing, I found that the new firmware is working both in standalone and VI after all, at least a LITTLE better than the previous firmware.
- the only problem with the firmware I experience now, is that if I automate more than 2 parameters (does not matter which ones), I get weird dropouts, tempo changes and random note playback. In the previous firmware, I also had this problem, but then with more than 1 parameter. I have sent demo files to your developer Salvator regarding this earlier on.
- And about the new Moog USB MIDI Driver - I have tried reinstalling this a couple of times now, restarted computer, synth, etc - but it does not work at all. "Moog Sub Phatty" does not show up in the device list in Preferences, and "hardware disconnected" is showing. Both in standalone and VI.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Need Sub Phatty editor and firmware update any news?

Post by Amos » Thu Oct 16, 2014 10:51 am

Denim wrote:- And about the new Moog USB MIDI Driver - I have tried reinstalling this a couple of times now, restarted computer, synth, etc - but it does not work at all. "Moog Sub Phatty" does not show up in the device list in Preferences, and "hardware disconnected" is showing. Both in standalone and VI.


when the driver is installed, does *ANYTHING* show up in the device list? Do you see a device with the names MIDI IN and MIDI OUT, by any chance?

Post Reply