Page 2 of 2

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 01, 2014 2:33 pm
by jido-genshi
mmarsh100 wrote:A different view: after some trouble getting 1.0.2 onto the 37, it is now rock solid. I have had zero issues with freezes.


Well, I too thought it was rock solid; that lasted about 3 days before my old Boom Bah crash came back.

And yes, it's not just that specific preset, it must have something to do with the way the sound is actually made (looping envelops while sequencing? I don't know.) The strange thing for me though is, it ONLY does happen with that preset in my case. I've already made my own, fairly complex sounds (even in Firmware 1.0.1) with looping envelops while sequencing, etc. and it doesn't freeze on me. The reason I will not remove the Boom Bah preset is because I am trying to troubleshoot this to see if I can figure out exactly what is causing the freeze (that obsession comes from years of working as a product test manager.)

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 01, 2014 2:51 pm
by Toom
I've noticed that it won't freeze patches that are prone to freezing if:

—You hold a key while switching to that patch
—You wait till the note has passed through the envelope before switching the patch.

It will freeze if:

—The note is not pressed but is going through the envelope as you switch to the patch.

I've tested this repeatedly and this is how I manage to freeze or not freeze these patches. (Boom Bah, or other patches that are freezing)

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 01, 2014 5:11 pm
by jido-genshi
Toom wrote:I've noticed that it won't freeze patches that are prone to freezing if:

—You hold a key while switching to that patch
—You wait till the note has passed through the envelope before switching the patch.

It will freeze if:

—The note is not pressed but is going through the envelope as you switch to the patch.

I've tested this repeatedly and this is how I manage to freeze or not freeze these patches. (Boom Bah, or other patches that are freezing)


Very interesting and insightful find! I will test this as well. I'll admit I haven't been testing this issue as much as I had planned on because I've been having too much fun creating music, but this is a pretty serious issue and hopefully it'll get resolved soon!

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Tue Sep 02, 2014 7:20 pm
by Amos
hey all, I've fixed this freeze bug! It was indeed related to patches with envelope Latch turned on... and also related to the behavior of switching presets while the EG is in its Release phase.

I will make a test build in the morning; I'd love to send it to a couple folks from this thread to confirm that it works for you as well.
If you'd like to test the fix please get in touch.

Cheers,

Amos

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Tue Sep 02, 2014 8:06 pm
by Toom
Nice one Amos!

I'm definitely interested in testing it out. Keep me posted.

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Tue Sep 02, 2014 10:40 pm
by jido-genshi
Amos wrote:hey all, I've fixed this freeze bug! It was indeed related to patches with envelope Latch turned on... and also related to the behavior of switching presets while the EG is in its Release phase.

I will make a test build in the morning; I'd love to send it to a couple folks from this thread to confirm that it works for you as well.
If you'd like to test the fix please get in touch.

Cheers,

Amos


I'm interested as well; sent a private message with my email address. Thanks for the support!

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Sat Sep 06, 2014 10:21 am
by bartleby
ok, so i downloaded and installed v1.0.3 from this thread and used it for a couple of hours today.

the good news:
i had no more freezes while switching between patches.
(instead a had a few hanging notes when switching patches while in sequencer latch mode)

the bad news:
i did have three temporary freezes while playing back internal sequences using sequencer latch mode. all three times, playback stopped, the s37 was completely unresponsive for a while, and then resumed playing the sequence again.

also, panel mode still doesn't always seem to read the current position of the rotary switches (mod1/2 source and osc1/2 octave).

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Sun Sep 07, 2014 7:46 am
by BrufordRules
Finally I could play my Sub 37 for a little while and the first problem I found was that after activating PANEL button the synth doesn't read all parameters properly i.e. LFO waveform and oscillators octave. I think this issue was commented by someone else previously.

I have to try the Presets issue.

Cheers

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 08, 2014 2:02 pm
by gencomprodukts
Hi,
Just to know, should i send all previous firmware updates before sending the 1.0.3
Since the 1.0.1 & 1.0.2 are available on Moogmusic.com, i was wondering...
Thanks in advance.

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 08, 2014 2:32 pm
by Amos
gencomprodukts wrote:Hi,
Just to know, should i send all previous firmware updates before sending the 1.0.3
Since the 1.0.1 & 1.0.2 are available on Moogmusic.com, i was wondering...
Thanks in advance.


No, this is not needed. You can update directly to 1.0.3.

Re: Sub 37 Firmware 1.0.2 Bugs

Posted: Mon Sep 08, 2014 2:37 pm
by gencomprodukts
All right, thanks for your answer Amos.