Moog Music Forum

Share Ideas and Pass the word

Grandmother PB wheel issue - Firmware 1.0.2 general problem?

Tabletop Semi-Modular Analog Synthesizers

Grandmother PB wheel issue - Firmware 1.0.2 general problem?

Postby Simon28 » Tue Apr 16, 2019 12:40 pm

Hi all owners of a grandmother ;)

The manual of the GM clearly states the following:

PITCH BEND RANGE
The pitch bend range of Grandmother’s PITCH wheel can be set anywhere from 1 to 12 semitones. To
adjust the Pitch Bend Range setting, press the (D#1) key, and then use the lowest 12 white keys (F0 to
C2) to select the corresponding number of semitones (1-12). The Default is 2 semitones.


I noticed, that the default on my synth is about 1/4 st, instead of 2 st. Also the PB wheel appeared to bend more down, than up (asymmetrical) and not according to the settings described in the manual.

Also my MOD-wheel was never 0%, so a calibration was recommended after contacting support. At this point I have to strongly advise:
Dear Moog team - you could save a lot of time and effort (for you and us customers) by just recommending to do a calibration in your manual or while registering, and make those files accessible immediately, not after we contacted you. Especially since it seems to be a necessary standard-procedure for most if not all GMs.

Anyways alot of time spent on analysis what the heck is going on, but back to the case. The mentioned calibration fixed a lot, my synth started to behave more as it should in general but the PB-wheel...

A. I realized, that the GLOBAL SETTINGS / Pitch Bend Range settings (D#1) menu allows me to actually press the white keys F0 to D2 and interprets them in the PB-ranges 0-12st
(F0=0st, G0=1st, ... to D2=12st) opposing the manual, which clearly states F0 to C2 allowing 1-12st. ???

B. The PB wheel never returns to the value (MIDI and pitch) I started from. If released snappy, it is acceptable, but if bending slowly back to 0-ish, it lands around +-35c of the original PB (on 12st PB range setting), which is a around 3/4 st apart and very apparent. Also the MIDI-data is drifting around accordingly, never going back to 0-ish again, but has an offset 600 up and it never reaches -100% value, despite calibration.

C. According to the real selectable PB intervals it all makes more sense now, but the PB wheel still bends around a 1/2 st too low up and down on 12 st PB interval settings. So it would go up +11,5 and down -12,5 st instead of +-12st.

My problem is that I can hear of course the PB being off while bending and also the pitch rarely getting back to an acceptable starting pitch after bending... it just sounds horrible.

Now the Moog customer services stated:
"The Grandmother is meant to behave more like a purely analog synth and is thus calibrated as such. This means that it may not always achieve the most accurate settings that a hybrid or digital synth could achieve. The additional MIDI implementation is a nice feature to have, but some discrepancies will be present due to the calibrations and the nature of the synth."

Please note:
I do have purely analog (and yes, really old) devices. I can adjust the PB range by ear on each of them and return to the starting pitch on each of them in a way, that it never hurt my ears had I never started measuring them and I don't care about MIDI data, if the thing does, what it should and it sounds good.

So what do you think?

1. Does your GM behave similarly?

2. Do you think, that this is acceptable "analog" discrepancies and not just poor behavior?
Last edited by Simon28 on Thu May 02, 2019 4:32 pm, edited 1 time in total.
Simon28
 
Posts: 4
Joined: Tue Apr 16, 2019 11:31 am

Re: Grandmother PB wheel issue

Postby filtered » Mon Apr 29, 2019 2:55 pm

I have the same issue- I set it to a whole step because the +12 setting was really a minor 7th, and wouldn't return 100% to the right root pitch- I sent a note to cust care and was told that an upcoming firmware release will address this- When performing I've been used to a whole octave, so it's taken some getting used to- hopefully that fix somes sooner than later...
http://www.youtube.com/user/moogslob?feature=mhee
http://www.carversmusic.com
http://www.moped10.com
[url]http://www.facebook.com/pages/The-NoSeRiDeRs/​81571989428[/url]
User avatar
filtered
 
Posts: 268
Joined: Sun Jan 29, 2012 12:42 am

Re: Grandmother PB wheel issue

Postby Simon28 » Thu May 02, 2019 4:31 pm

Thanks for your feedback! Do you have firmware 1.0.2? (see below why I ask)


I have sent one GM back by now and got back two by a mistake. After updating both to FW 1.0.2, they both started to show the same misbehavior. Before that they just worked fine.

It seems to be a firmware issue then that Moog does not know about. In fact support told me to go to a repair shop with my GM and let them handle the problem.. after giving up on justifying it as a "analog imprecision".

Since support never told me it might be an issue of the firmware I had to now actually request one to be able to revert and test for a last time and be 100 % sure it is the firmware (and not e.g. the updating process or similar). Waiting for that right now.


Sum up:
1. Def. 3 synths with firmware 1.0.2 were behaving all off PB-wise (as described in my first post)
2. 2 of them def. worked properly before (no idea which firmware version)
Simon28
 
Posts: 4
Joined: Tue Apr 16, 2019 11:31 am

Re: Grandmother PB wheel issue - Firmware 1.0.2 general prob

Postby watah » Tue May 07, 2019 8:38 pm

Just checking in to say I have this EXACT same problem!
I bought my grandmother last week during the moogfest sale and I was wondering if people more people have a similar issue.

Hopefully a fix is coming soon, my pitchbend is unusable.
watah
 
Posts: 2
Joined: Tue May 07, 2019 8:16 pm

Re: Grandmother PB wheel issue - Firmware 1.0.2 general prob

Postby Simon28 » Wed May 08, 2019 7:43 am

Thanks for your feedback guys.

In the meantime I got firmware v.1.0.0 and loaded that to both, but there seems to be no change back, meaning the PB wheel problem stayed.
Now I am confused :P Especially since support told me, they don't really know, if or in which version it ever worked (?)

So I am still on the mission... (like for 1,5 month now, just to find out, whats going on).
Simon28
 
Posts: 4
Joined: Tue Apr 16, 2019 11:31 am

Re: Grandmother PB wheel issue - Firmware 1.0.2 general prob

Postby watah » Fri May 10, 2019 2:40 pm

I figured out how to fix mine.

You have to recalibrate your potentiometers.

https://www.reddit.com/r/moog/comments/ ... re_issues/

https://www.sweetwater.com/sweetcare/ar ... nd-update/

See these two posts.
watah
 
Posts: 2
Joined: Tue May 07, 2019 8:16 pm

Re: Grandmother PB wheel issue - Firmware 1.0.2 general prob

Postby Simon28 » Sat May 11, 2019 11:14 am

Hi, thanks for your links.
If you read my post at the beginning and later, I already had 3 Grandmothers to experiment with and I calibrated them all.

The first one had a calibration issue indeed, but also the described error AFTER calibrating.
The other two worked fine when received, but as soon as they got firmware 1.0.2 the PB-wheel issue showed up the same way and does not go away with reverting it to either v1.0.0 nor v0.7.7 (got them from Moog support).

Also Moog support wrote me meanwhile:
"The problem has been identified as a firmware bug by our engineers. We've been able to recreate the problem on our Grandmother here using the current firmware available. As for when this bug was introduced (or whether its been present through every firmware revision so far) I cannot say for certain. I suspect the reason this issue has not come up more often is simply due to how others are using the Grandmother in their setup. (...) And yes, I can confirm after testing several Grandmothers that the pitch bend issue is a firmware bug, and not a physical problem with the device itself."
Simon28
 
Posts: 4
Joined: Tue Apr 16, 2019 11:31 am


Return to Grandmother, Mother-32 & DFAM

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests