Page 1 of 1

MF Delay Problem with Synth

PostPosted: Wed Aug 05, 2015 1:03 pm
by joostoftoday
Hey everyone!

I have a problem with my MF Delay. When I first got it, I tried using it with a toy keyboard and my smartphone just to test the delay function and everything functioned very well. But when I tried this with my synths at home and using it as an AUX send for my mackie (1642vlz-pro)-mixer, suddenly all I get is crackling, distortion and a feedback loop.
I already searched this forum for some help, but everyone wrote that you can use this pedal with synths and as an AUX send without any problems.
Can someone help me?

Re: MF Delay Problem with Synth

PostPosted: Thu Aug 06, 2015 11:19 am
by Gladmarr
Go back to testing it where it did work. Make sure something on it works the way it's supposed to.

Re: MF Delay Problem with Synth

PostPosted: Thu Aug 06, 2015 12:28 pm
by Moog Music
joostoftoday wrote:Hey everyone!

I have a problem with my MF Delay. When I first got it, I tried using it with a toy keyboard and my smartphone just to test the delay function and everything functioned very well. But when I tried this with my synths at home and using it as an AUX send for my mackie (1642vlz-pro)-mixer, suddenly all I get is crackling, distortion and a feedback loop.
I already searched this forum for some help, but everyone wrote that you can use this pedal with synths and as an AUX send without any problems.
Can someone help me?


The MF Delay is designed for instrument level inputs, whereas your mixer is outputting a line level signal. This is overdriving the input of your MF Delay. Simply reduce your send levels and the issue will go away.

-Your friends at Moog