MF Delay Problem with Synth

Welcome to the world of Minifooger Analog Effects
Post Reply
joostoftoday
Posts: 1
Joined: Wed Aug 05, 2015 11:45 am

MF Delay Problem with Synth

Post by joostoftoday » Wed Aug 05, 2015 1:03 pm

Hey everyone!

I have a problem with my MF Delay. When I first got it, I tried using it with a toy keyboard and my smartphone just to test the delay function and everything functioned very well. But when I tried this with my synths at home and using it as an AUX send for my mackie (1642vlz-pro)-mixer, suddenly all I get is crackling, distortion and a feedback loop.
I already searched this forum for some help, but everyone wrote that you can use this pedal with synths and as an AUX send without any problems.
Can someone help me?

User avatar
Gladmarr
Posts: 141
Joined: Fri Aug 27, 2010 7:47 pm

Re: MF Delay Problem with Synth

Post by Gladmarr » Thu Aug 06, 2015 11:19 am

Go back to testing it where it did work. Make sure something on it works the way it's supposed to.
Image

Moog Music
Posts: 71
Joined: Fri Feb 10, 2012 11:09 am

Re: MF Delay Problem with Synth

Post by Moog Music » Thu Aug 06, 2015 12:28 pm

joostoftoday wrote:Hey everyone!

I have a problem with my MF Delay. When I first got it, I tried using it with a toy keyboard and my smartphone just to test the delay function and everything functioned very well. But when I tried this with my synths at home and using it as an AUX send for my mackie (1642vlz-pro)-mixer, suddenly all I get is crackling, distortion and a feedback loop.
I already searched this forum for some help, but everyone wrote that you can use this pedal with synths and as an AUX send without any problems.
Can someone help me?


The MF Delay is designed for instrument level inputs, whereas your mixer is outputting a line level signal. This is overdriving the input of your MF Delay. Simply reduce your send levels and the issue will go away.

-Your friends at Moog

Post Reply