Page 2 of 2

Re: MF Drive dead already

PostPosted: Tue Mar 15, 2016 2:21 am
by aisling
this just happened with my MF delay (4 months out of warranty). It took moog a few weeks to answer me back and initiate an RMA, It also took them a few weeks once they received the unit, but they gave me a brand new one. They did me right! :D

Re: MF Drive dead already

PostPosted: Wed Apr 20, 2016 6:56 pm
by Vsyevolod
soulmanure wrote:I'm having this problem now as well. I contacted customer service, but haven't gotten a response


Vsyevolod wrote:Call them, don't write.


Stephen




.

Re: MF Drive dead already

PostPosted: Wed Sep 26, 2018 2:55 pm
by mount olive music
Same issue here.

Re: MF Drive dead already

PostPosted: Wed Sep 26, 2018 3:37 pm
by mount olive music
soulmanure wrote:I'm having this problem now as well. I contacted customer service, but haven't gotten a response--they're probably working pretty hard, especially with the mothers landing. In any case, it happened to me a while back with my drive--just wouldn't start up, and this is with the proper Moog power supply. Then, voila, it worked for about a year or so. Now, it's happening again. Sometimes it turns on, sometimes it doesn't. The light will engage on power up, then nothing. It's pretty odd, and it's the only pedal on my board that this is happening with. So I'm wondering if anyone's figured out what the story is on this issue. My drive is out of warranty now, alas, but perhaps there's a work around!


my sentiment exactly! Paid $150 for NOS on ebay and was in love for a few weeks at best. then it just died. Then it worked again. Then it died. Sent it in with rma. Now it works there and they are sending it back i guess? So After 30 years of buying and using pedals, my first bad experience. Sucks because I really love the sound of the mf drive. Seems to be a well known issue in the online community? You would think they would know as well. Needless to say, i am very weary of a product and company i always believed to be top of the line.