Moog Music Forum

Share Ideas and Pass the word

Model 15 MIDI CC Out is Jumpy

Share Model D, Model 15, Animoog and Filtatron tips and tricks. Unleash your creations on the world.

Model 15 MIDI CC Out is Jumpy

Postby dysamoria » Sat Dec 31, 2016 3:03 pm

Hi again,

i've been trying to use Model 15 as a MIDI controller for stuff in Logic Pro 9.x. The behavior is stuttery/jumpy. Looking at the MIDI data with a MIDI monitor confirms the data is coming into the computer this way (chunks of CC messages are dropped), but the activity light on the MIDI interface (Edirol UM-1ex) is not showing the jumpy behavior. i am wondering if it is the fact that the UM-1ex is sending Active Sensing messages. i cannot disable this.

i have no other apps on my iPad that send MIDI data to test with to see if it is Model 15 or something else.

Any ideas?
dysamoria
 
Posts: 16
Joined: Thu Dec 22, 2016 9:09 pm

Re: Model 15 MIDI CC Out is Jumpy

Postby Satri » Sat Dec 31, 2016 3:17 pm

Hi Dysamoria,

I suspect your issue might be related to not using MIDI MPE. Are you using MIDI MPE? In Model 15, you'll find it under Setting => MIDI => Channel => MPE (at the very bottom of the list).

Modern MIDI controllers such as Animoog and Model 15 probably require the use of MIDI MPE in order to properly convey all the MIDI messages to other apps without any gaps. Here's a related reference: https://www.animoog.org/2015/11/16/the- ... d-animoog/ Note that Animoog and Model 15 both support MIDI MPE, as well as numerous MIDI controllers (the LinnStrument, ROLI Seaboard, etc). The Wikipedia article has currently little to offer regarding this extension of the standard.

According to my quick search on the web, Logic Pro X supports MIDI MPE. I don't know if 9.x does as well.

Hope this helps -- Alex / Satri
Animoog Beta Tester | Free albums of Animoog solos on animoog.org/satri/ | satri.bandcamp.com | Theremini | ROLI Seaboard RISE 49 | iPad Air | Alex / Satri
User avatar
Satri
 
Posts: 173
Joined: Sat Nov 19, 2011 3:48 pm
Location: Montreal, Canada

Re: Model 15 MIDI CC Out is Jumpy

Postby dysamoria » Sat Dec 31, 2016 4:40 pm

It appears that MPE is for MIDI input only, not MIDI output.
dysamoria
 
Posts: 16
Joined: Thu Dec 22, 2016 9:09 pm

Re: Model 15 MIDI CC Out is Jumpy

Postby Satri » Sat Dec 31, 2016 6:16 pm

dysamoria wrote:It appears that MPE is for MIDI input only, not MIDI output.


Re-reading the Model 15 app description, you seem to be right! Sorry for the confusion. Someone from Moog might chime in to better answer your question than I did!

Happy new year nonetheless :-) -- Alex / Satri
Animoog Beta Tester | Free albums of Animoog solos on animoog.org/satri/ | satri.bandcamp.com | Theremini | ROLI Seaboard RISE 49 | iPad Air | Alex / Satri
User avatar
Satri
 
Posts: 173
Joined: Sat Nov 19, 2011 3:48 pm
Location: Montreal, Canada

Re: Model 15 MIDI CC Out is Jumpy

Postby dysamoria » Sat Dec 31, 2016 6:19 pm

Thanks for trying :-) Have a good one
dysamoria
 
Posts: 16
Joined: Thu Dec 22, 2016 9:09 pm

Re: Model 15 MIDI CC Out is Jumpy

Postby Satri » Sun Jan 01, 2017 9:44 pm

Ah... sometimes, my memory is pretty bad :-) We were both involved in a recent thread (viewtopic.php?f=13&t=24292&p=160898#p160898 ) where Geert clearly specified that MIDI MPE output was considered for the future but not something available today. Happy new year! -- Alex
Animoog Beta Tester | Free albums of Animoog solos on animoog.org/satri/ | satri.bandcamp.com | Theremini | ROLI Seaboard RISE 49 | iPad Air | Alex / Satri
User avatar
Satri
 
Posts: 173
Joined: Sat Nov 19, 2011 3:48 pm
Location: Montreal, Canada

Re: Model 15 MIDI CC Out is Jumpy

Postby dysamoria » Sun Jan 22, 2017 9:17 pm

Anyone else experiencing jumpy MIDI CC output from the Model 15 app to another device?
dysamoria
 
Posts: 16
Joined: Thu Dec 22, 2016 9:09 pm

Re: Model 15 MIDI CC Out is Jumpy

Postby dysamoria » Fri Oct 27, 2017 2:49 pm

*BUMP*
:-)
dysamoria
 
Posts: 16
Joined: Thu Dec 22, 2016 9:09 pm


Return to Moog Apps

Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest