Taurus 3 firmware update v1.2 - now with new features!

Welcome to the Taurus, Minitaur and Sirin Forum
Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Mon Apr 16, 2012 6:01 pm

OK, here's a new version to test.

I labeled this one "1.23" but I have made so many changes, I will call this version 2.0 once it is all tested and approved for release.

I apologize, I still need to document a lot of the new stuff.
A very short description:

all sound parameters now send/receive MIDI. Added Filter, Volume, Resonance velocity sensitivity, MIDI Note OUT transpose per
preset, global MIDI Note IN and OUT transpose, Midi Message filtering (IN and OUT), MIDI Sync control (set MIDI Clock Start and Stop behavior).

Some of this stuff was already in the previous beta-version, some of it is brand new, especially the resonance velocity sensitivity and the MIDI Sync Start and Stop settings.
Check the Advanced Preset menu and the MIDI SETUP menu for all the new stuff.

Resonance and Filter sensitivity work as follows.
If amount is zero, velocity has no effect on the parameter. If amount is >0, then the behavior is (with amount >> 0) max velocity gives 100% of the amount of resonance as set by the Resonance parameter (or filter cutoff), less velocity gives a lower parameter value. If amount is <0, then minimum velocity gives 100% of the parameter value as set in the normal way, and higher velocity gives a lower parameter value. It may seem a little confusing, since it's not so simple as "more velocity = more parameter value" since you never exceed the maximum parameter value you've set normally. if the parameter value is zero to begin with, then velocity won't change it... have to set the parameter to a high value and then use velocity to scale that. Hope this makes sense.

MIDI Sync stuff works like this:

Sync Start: "any clock" or "start msg" -- the arpeggiator for instance, if clock source = MIDI... old behavior was to lock to MIDI Sync as soon as any MIDI clock is detected. If Sync Start is set to Start Msg, then the arpeggiator will not sync to MIDI unless an actual MIDI Start message is received.
Sync Stop: settings are: "Internal Clock" or "Dead Stop." Internal Clock is the old/default setting; in this mode if the arpeggiator is following MIDI clock and the clock is stopped, the arpeggiator switches to an internal clock at the same rate and continues running. If set to "Dead Stop" then if the arpeggiator is set to MIDI clock and the clock is stopped, the arpeggiator stops. The arpeggiator will restart on a midi Start message and will resume running (without restarting the arpeggio pattern) on a MIDI Continue message. Be advised that if Sync Start is set to Start Msg and Sync Stop is set to Dead Stop, then the arpeggiator will not run at all if it is set to MIDI Clock and there is no MIDI clock / no MIDI Start message being sent to the Minitaur. This could be useful for some performers who would like the arpeggiator not to run until they hit Start on a sequencer.

I am hoping to get some good testing and feedback on this version also, so I'm putting it out here without any further delay... but I will complete the documentation process for this new version as soon as I can.

Here are the files:

Mac: http://seamslikereality.com/moog/Taurus ... 12_OSX.zip
Windows: http://seamslikereality.com/moog/Taurus ... 12_WIN.zip
Last edited by Amos on Thu Apr 19, 2012 11:29 am, edited 2 times in total.

User avatar
bichuelo
Posts: 821
Joined: Fri Jan 22, 2010 5:25 pm
Location: Bogotá, Colombia
Contact:

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by bichuelo » Mon Apr 16, 2012 6:36 pm

Hi Amos,

Thanks for the update, I will try it right away!

Will this new version include the Velocity Off value to Decay parameter? That would make the pedals truly expressive.

Cheers :P
http://audiotecna.info
T-III, Voyager, VX-351, Slim Phatty, Model D, Sub Phatty, Subsequent 37, Minitaur, all moogerfoogers and minifoogers, EW+, Theremini, Model 15, Filtatron, Animoog, Model D App, iOS 11 Mother-32, DFAM, Werkstatt, Win7, High Sierra

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Mon Apr 16, 2012 9:08 pm

bichuelo wrote:Hi Amos,

Thanks for the update, I will try it right away!

Will this new version include the Velocity Off value to Decay parameter? That would make the pedals truly expressive.

Cheers :P


No, I did not have time to add this. Sorry!

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Mon Apr 16, 2012 9:10 pm

Also: I hope all new parameters and global values will be initialized correctly and automatically.

However, if any strange behavior is found, I recommend a factory restore as the first step (after saving your presets as sysex, of course).

User avatar
bichuelo
Posts: 821
Joined: Fri Jan 22, 2010 5:25 pm
Location: Bogotá, Colombia
Contact:

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by bichuelo » Tue Apr 17, 2012 3:07 pm

Amos wrote:
bichuelo wrote:Hi Amos,

Thanks for the update, I will try it right away!

Will this new version include the Velocity Off value to Decay parameter? That would make the pedals truly expressive.

Cheers :P


No, I did not have time to add this. Sorry!


Oh, its such a shame that even though the pedals have a Note Off Velocity feature, it is simply not used

Will there be a MIDI Thru function on the new firmware?
http://audiotecna.info
T-III, Voyager, VX-351, Slim Phatty, Model D, Sub Phatty, Subsequent 37, Minitaur, all moogerfoogers and minifoogers, EW+, Theremini, Model 15, Filtatron, Animoog, Model D App, iOS 11 Mother-32, DFAM, Werkstatt, Win7, High Sierra

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Tue Apr 17, 2012 3:57 pm

bichuelo wrote:
Amos wrote:
bichuelo wrote:Hi Amos,

Thanks for the update, I will try it right away!

Will this new version include the Velocity Off value to Decay parameter? That would make the pedals truly expressive.

Cheers :P


No, I did not have time to add this. Sorry!


Oh, its such a shame that even though the pedals have a Note Off Velocity feature, it is simply not used

Will there be a MIDI Thru function on the new firmware?


Maybe I can still add some use of Note Off velocity later. As for MIDI Thru, there was always a MIDI Merge function... it merges clocks now also, so I think it will work as a Thru.

Mr Arkadin
Posts: 597
Joined: Fri Jun 06, 2008 8:43 am

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Mr Arkadin » Tue Apr 17, 2012 8:03 pm

So far I have been unable to make this update work. I get no receiving signal on my Taurus even though it is set to software update: on.

Anyone got this to work?
http://soundcloud.com/luke-antony

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Wed Apr 18, 2012 9:19 am

Hang on, looks like I may have had one setting incorrect when building the firmware update files... an easy fix but it would explain why the update did not work for you. One moment; I will fix.

Tested working now... same file names on my server; re-download and replace older files if needed.


Mac: http://seamslikereality.com/moog/Taurus ... 12_OSX.zip
Windows: http://seamslikereality.com/moog/Taurus ... 12_WIN.zip

Amos
Last edited by Amos on Thu Apr 19, 2012 11:29 am, edited 3 times in total.

Mr Arkadin
Posts: 597
Joined: Fri Jun 06, 2008 8:43 am

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Mr Arkadin » Wed Apr 18, 2012 10:09 am

Those new links are broken, but I used the old one OK.

After update the screen stays stuck on Taurus 3 (C) 2009 rather than resetting properly. I turned the unit off and on and it seems to work normally and shows the new update FW number.

However, when I select the Taurus 3 preset the Glide LED is off, but the glide is definitely on. If I press the Glide footswitch off then back on the LED is reactivated. However if I go to another preset with glide the LED again deactivates itself. Also some presets like B2 Gordon have become silent (also silent: G4 Wah Arp, H3 Ferdinand, I3 WestBoom). I haven't tried reloading the presets from the 1.13 file yet.
http://soundcloud.com/luke-antony

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Wed Apr 18, 2012 10:11 am

obviously, something isn't being initialized properly on first boot after the update. Try a factory restore and see if it puts things right. Meanwhile I'll see if I can correct the problem at the source.

Mr Arkadin
Posts: 597
Joined: Fri Jun 06, 2008 8:43 am

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Mr Arkadin » Wed Apr 18, 2012 10:56 am

Tried Factory Restore: no difference.

Tried re-flashing again: this time it rebooted properly (didn't stick on copyright notice) but the other symptoms (glide LED, silent presets) are the same.

Tried both Factory and Master reboots again. Same issues as previously mentioned,
http://soundcloud.com/luke-antony

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Wed Apr 18, 2012 11:18 am

Mr Arkadin wrote:Tried Factory Restore: no difference.
Tried both Factory and Master reboots again. Same issues as previously mentioned,


OK, back to work for me then. FYI, 'Master Reboot' doesn't change any data, it just reboots the unit (like flipping the power off/on). I added a lot of new parameters, so I'll have to see what might have changed to cause the silent presets. Thanks for the feedback... more soon....

Mr Arkadin
Posts: 597
Joined: Fri Jun 06, 2008 8:43 am

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Mr Arkadin » Wed Apr 18, 2012 11:24 am

Oh, I just tried the Decay LED and that seems disabled initially too, even if the preset has Decay on.
http://soundcloud.com/luke-antony

francesco
Posts: 26
Joined: Tue Apr 29, 2008 5:42 am

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by francesco » Wed Apr 18, 2012 1:03 pm

Hi!

My additional observations with FW 1.23:

- The glide LED has the same "problem" as the decay LED
- velocity -> filter cutoff has no effect, velocity -> resonance and velocity -> volume working very well
Synths: Moog MiniTaur, Taurus III, Voyager RME & VX351& VX352 & CP251 & MP201 DAW: Cubase 8.5 on WIN10 AMD Phenom II X6

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: Taurus 3 firmware update v1.2 - now with new features!

Post by Amos » Wed Apr 18, 2012 5:24 pm

Thanks, you guys!

I uploaded a v1.24 which fixes the presets that were not playing...

have not fixed the other items (panel LEDs, velocity->cutoff) but I'll get to them in the morning.

Thanks so much for your help! There were so many changes, it's really useful now to have some additional eyes looking at the work in progress.

Mac: http://seamslikereality.com/moog/Taurus ... 12_OSX.zip
Windows: http://seamslikereality.com/moog/Taurus ... 12_WIN.zip

cheers,

Amos

Post Reply