MP-201 firmware v2.0 missing a "8 triple"

This is the place to share tips, tricks and questions about Moog's controller products; the MP-201 Multi-Pedal and the EP-2. There are a world of applications for these expression enhancers. Explore...
MichaelPeterTrowbridge
Posts: 107
Joined: Tue Mar 25, 2008 4:08 am

MP-201 firmware v2.0 missing a "8 triple"

Post by MichaelPeterTrowbridge » Tue Dec 08, 2009 9:38 am

Hello everyone

I already posted this question in the main thread about the new MP-201 firmware. Since I didn't get any clues there, I thought I might as well just open a new topic.

In one song of our forthcoming EP I was using a Triangle-LFO from the MP-201 (synced to my HR-16) to control the RingModulator (via Carrier-In) functioning as a Tremolo. I used the speed "8 triple".

Now that I've upgraded I found many other useful features, but am lacking that option. My questions therefore are:

A) Is this ought to be this way?
B) How can I still get the "8 triple"-setting using the new firmware?

Thanks,
Michael

MichaelPeterTrowbridge
Posts: 107
Joined: Tue Mar 25, 2008 4:08 am

Post by MichaelPeterTrowbridge » Wed Feb 03, 2010 6:27 am

bump

ebo
Posts: 135
Joined: Mon Oct 26, 2009 8:41 pm

Post by ebo » Mon Feb 08, 2010 7:29 am

hi ! my wishlist in topic: MP201 V3.ebo.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Post by Amos » Tue Feb 09, 2010 9:16 pm

this was my mistake. I plan to add more clock divisions to the next MP-201 firmware update, including all the triplet values.

-Amos

innerloop
Posts: 4
Joined: Sat Aug 14, 2010 9:50 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by innerloop » Sat Aug 14, 2010 10:13 am

Amos, can you please add these triplets ASAP? I just got the software v 2.0 and I was shocked to find the lack of the triplets. triplets are essential to making music so they are gravely missed. Most of my settings were for triplets and without them the MP-201 becomes in my opinion more rigid rythymically speaking. I noticed that you posted your response in February and it's now August. These triplets should have been immediatley added back into a version 2.1 or whatever. Don't get me wrong. I appreciate the wonderful additions you included in v 2.0 but the lack of triplets kind of tarnishes what would be truly an amazing software update. Can you at least tell us when you plan on releasing this new firmware? If it is later as opposed to sooner can you please release something that just fixes the triplet ommision? Thanks, much appreciated.

digbysellers
Posts: 14
Joined: Fri Dec 04, 2009 3:40 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by digbysellers » Tue Aug 02, 2011 12:57 pm

Triplets. I really need this. It's kind of putting a downer on the whole device, makes me leave it on the shelf...

MichaelPeterTrowbridge
Posts: 107
Joined: Tue Mar 25, 2008 4:08 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by MichaelPeterTrowbridge » Fri Aug 05, 2011 10:10 am

Triplets, triplets, triplets.

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by Amos » Wed Aug 10, 2011 2:05 pm

working on this today... you have my heartfelt apology for the year's delay.

Now that Phatty firmware update is finished and MF-108 firmware is in beta, I had a day to work on MP-201.

MP201 now has the following clock divisions:

{"8 WH","4 WH","3 WH","2 WH","WH DOT","WHOLE","1/2 DOT","WH TRIP","1/2","1/4 DOT","1/2 TRIP","1/4","1/8 DOT","1/4 TRIP","1/8","1/16 DOT","1/8 TRIP","1/16","1/16 TRIP","1/32","1/32 TRIP"};

... I had to shorten "WHOLE" to "WH" in the menu text in order to make enough code space... :)

MichaelPeterTrowbridge
Posts: 107
Joined: Tue Mar 25, 2008 4:08 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by MichaelPeterTrowbridge » Sat Aug 13, 2011 6:22 am

Amos wrote:working on this today... you have my heartfelt apology for the year's delay.

Now that Phatty firmware update is finished and MF-108 firmware is in beta, I had a day to work on MP-201.

MP201 now has the following clock divisions:

{"8 WH","4 WH","3 WH","2 WH","WH DOT","WHOLE","1/2 DOT","WH TRIP","1/2","1/4 DOT","1/2 TRIP","1/4","1/8 DOT","1/4 TRIP","1/8","1/16 DOT","1/8 TRIP","1/16","1/16 TRIP","1/32","1/32 TRIP"};

... I had to shorten "WHOLE" to "WH" in the menu text in order to make enough code space... :)


Splendid! You've made my day Amos! When and where will we be able to download the new OS?

digbysellers
Posts: 14
Joined: Fri Dec 04, 2009 3:40 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by digbysellers » Wed Aug 17, 2011 1:47 pm

Oh yes!!! My week off is coming, will have time to play!
How to get it? The software section on the product page says 2.0?

User avatar
mico
Posts: 159
Joined: Wed Apr 13, 2011 3:29 am
Location: Washington, DC

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by mico » Thu Aug 18, 2011 4:03 am

Amos wrote:working on this today... you have my heartfelt apology for the year's delay.

Now that Phatty firmware update is finished and MF-108 firmware is in beta, I had a day to work on MP-201.

MP201 now has the following clock divisions:

{"8 WH","4 WH","3 WH","2 WH","WH DOT","WHOLE","1/2 DOT","WH TRIP","1/2","1/4 DOT","1/2 TRIP","1/4","1/8 DOT","1/4 TRIP","1/8","1/16 DOT","1/8 TRIP","1/16","1/16 TRIP","1/32","1/32 TRIP"};

... I had to shorten "WHOLE" to "WH" in the menu text in order to make enough code space... :)

This is absolutely fantastic!

Amos, I do hope you come to the aid of us T3 users soon. I feel confident enough to say (while in truth I only speak for myself), we look forward to an update for the T3.

::cough::KB (or PB? :P) LFO retriggering::cough:: :D
Moog Sub 37 (#0133), Ibanez M80M, & Doomy Bow
MF-102 • MF-103 • MF-105m • KE Kommander • MHI B:a (Germ. w/EQ mod) • Strymon Timeline
Previous: Model D, Taurus, Taurus III, Little Phatty SE II (Solar Edition w/CV Out mod), Sub Phatty

digbysellers
Posts: 14
Joined: Fri Dec 04, 2009 3:40 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by digbysellers » Fri Aug 19, 2011 11:04 am

How do I get hold of this update? Can't wait to get into it!

Amos
Posts: 2438
Joined: Wed Jul 23, 2003 3:11 pm

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by Amos » Fri Aug 19, 2011 4:31 pm

Hi all... here is an update.
I had a bit of trouble with this; i can't *guarantee* the update will work.
After some more work today I have it updating reliably with no errors, on my MP201.
So, please understand you're a beta tester if you want to try this :)
However, even when I had errors I could always re-load the v2 firmware without fail.

Update instructions, mac and windows files are all in here:

http://seamslikereality.com/moog/mp201/ ... Update.zip

[*NOTE: you MUST use the MP201 USB connection to send the firmware update.]

enjoy! let me know how it works for you.

-Amos
Last edited by Amos on Fri Aug 26, 2011 3:31 pm, edited 1 time in total.

digbysellers
Posts: 14
Joined: Fri Dec 04, 2009 3:40 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by digbysellers » Sun Aug 21, 2011 10:51 pm

Thanks so much! I can't wait to try it. I should be through with exams by the end of the week and be able to test it. Awesome.

digbysellers
Posts: 14
Joined: Fri Dec 04, 2009 3:40 am

Re: MP-201 firmware v2.0 missing a "8 triple"

Post by digbysellers » Fri Sep 02, 2011 2:57 pm

Unfortunately, I tried, and reverted twice after receiving "Send FW Sysex Code error 2 2_" -Used the usb cable, windows xp sp3. Previous firmware was 2.0, having upgaded to this after purchasing. Will try on Windows7 netbook asap/tomorrow. Don't know what other information may be helpful?

Post Reply