Moog Music Forum

Share Ideas and Pass the word

Arpeggiating the Sub Phatty (iPad solution)

Little Phatty • Slim Phatty • Sub Phatty • Sub 37

Arpeggiating the Sub Phatty (iPad solution)

Postby dswo » Thu Mar 28, 2013 8:51 am

As of this writing, the Sub Phatty does not have a built-in arpeggiator. I don't if it will ever get one, but if you have an iPad and some kind of MIDI interface, there are some really good arpeggiator apps. I've tried two, Arpeggionome Pro and StepPolyArp. They're both fun, but the one I've gotten most use from is StepPolyArp. It can perform extremely complex note patterns, and it can also automate CC values. Neither app is expensive, but watch a few YouTube videos and see which one appeals to you.

My Sub Phatty hasn't arrived yet, but here's how I set up StepPolyArp with my first synth, an Akai Miniak:

1. In the app, set MIDI IN to the Sub Phatty and also MIDI OUT to the Sub Phatty.

2. On the Sub Phatty itself, turn MIDI Local Control off (p. 34 in the Sub Phatty manual). When you do this, the Phatty will send notes to SPA, but only play the notes that SPA sends back.

3. If you get stuck in a loop, check that MIDI Merge is off (pp. 33-34 in the Sub Phatty manual).
David Wilson-Okamura
User avatar
dswo
 
Posts: 211
Joined: Fri May 27, 2011 9:50 am
Location: East Carolina

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby mico » Thu Mar 28, 2013 9:08 am

I have just tested this with the SPA app and can confirm that this does indeed work. The only con with this app, at least with how I have it set up, the mod wheel position will default when changing the arpeggiation - not just the sequence, but even the key of the sequence within the app. Regardless though, this is a good solution to anyone who owns both an iOS device and a Sub Phatty.

Thank you for posing this solution in my other thread. This helps immensely.
Moog Sub 37 (#0133), Ibanez M80M, & Doomy Bow
MF-102 • MF-103 • MF-105m • KE Kommander • MHI B:a (Germ. w/EQ mod) • Strymon Timeline
Previous: Model D, Taurus, Taurus III, Little Phatty SE II (Solar Edition w/CV Out mod), Sub Phatty
User avatar
mico
 
Posts: 159
Joined: Wed Apr 13, 2011 3:29 am
Location: Washington, DC

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby dswo » Thu Mar 28, 2013 9:21 am

mico wrote:The only con with this app, at least with how I have it set up, the mod wheel position will default when changing the arpeggiation - not just the sequence, but even the key of the sequence within the app.


My SubP hasn't shipped yet, so I can't test this. But do try emailing the developer; I've found him to be very responsive.
David Wilson-Okamura
User avatar
dswo
 
Posts: 211
Joined: Fri May 27, 2011 9:50 am
Location: East Carolina

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby mico » Sat Mar 30, 2013 2:27 pm

As it turns out, turning Local Control off isn't working for me. I thought I was getting arpeggiation with my single-note programs due to seeing the pattern being sequenced by the Sub Phatty, but once I tried latch, it was quickly apparent that was not so. The attack when pressing each new key was gave it away.

I checked my Shift mode parameter selections again and again, including assuring myself that MIDI output was to Channel 1 (even though I know it is by default) but to no avail.

I should've tinkered around with this more when I initially tried it out. I'm surprised it took me this long to notice. I thought perhaps my arp was just that damn fast, but nope. Such is not the case.

Odd.
Moog Sub 37 (#0133), Ibanez M80M, & Doomy Bow
MF-102 • MF-103 • MF-105m • KE Kommander • MHI B:a (Germ. w/EQ mod) • Strymon Timeline
Previous: Model D, Taurus, Taurus III, Little Phatty SE II (Solar Edition w/CV Out mod), Sub Phatty
User avatar
mico
 
Posts: 159
Joined: Wed Apr 13, 2011 3:29 am
Location: Washington, DC

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby dswo » Sat Mar 30, 2013 2:37 pm

What happens when you turn local MIDI off and just play the keyboard without the iPad attached? Do you hear a note? If so, maybe there's a bug in the firmware. If you don't, perhaps you are caught in a MIDI loop. (Maybe check MIDI merge settings, pp. 33-34 in the manual.) Again, I'm sorry I can't test this at home: my preorder isn't scheduled to ship until Apr. 10.
David Wilson-Okamura
User avatar
dswo
 
Posts: 211
Joined: Fri May 27, 2011 9:50 am
Location: East Carolina

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby mico » Sat Mar 30, 2013 2:47 pm

dswo wrote:What happens when you turn local MIDI off and just play the keyboard without the iPad attached? Do you hear a note?

Correct. Even when the iPad is not attached, the keyboard a note to played by the Sub Phatty when Local Control is set to 'off'.

dswo wrote:If so, maybe there's a bug in the firmware.

That's what I'm thinking as well, but Amos didn't list it in the revisions being made in the post-release firmware update. There is a few items related to Local Control being fixed, but nothing as simple as its on/off function.

I will chime in over there in his post-release firmware thread.

I was hoping it was a MIDI merge setting issue myself, but when I initially figured out this problem (and just now), the Sub Phatty still functions as though Local Control is on when it is meant to be off. Unless there is an error in the manual; I did find it odd that 'off' would be selected by the low C key.

Thanks for the suggestion regardless.
Moog Sub 37 (#0133), Ibanez M80M, & Doomy Bow
MF-102 • MF-103 • MF-105m • KE Kommander • MHI B:a (Germ. w/EQ mod) • Strymon Timeline
Previous: Model D, Taurus, Taurus III, Little Phatty SE II (Solar Edition w/CV Out mod), Sub Phatty
User avatar
mico
 
Posts: 159
Joined: Wed Apr 13, 2011 3:29 am
Location: Washington, DC

Re: Arpeggiating the Sub Phatty (iPad solution)

Postby mico » Sun Mar 31, 2013 7:36 am

I just tried it by removing the DIN cables from both the MIDI In and Out of the Sub Phatty and Local Control is indeed off. I think what I'm dealing with is a MIDI echo from my iConnect MIDI interface feeding back into the MIDI In of my Sub Phatty. This is relieving, albeit still a frustrating matter.

Checked MIDI Merge parameters and MIDI Merge is 'off'.

Went into the PortManager app for iConnectMIDI and assured 'DIN 1' was routing to 'DIN 1'. This remedied the MIDI echo under some instances.

Within SPA's MIDI menu, under 'Midi in', I have checked 'iConnectMIDI iCM DIN 1' and under 'Channels to filter', I have highlighted '1'. Doing this results in SPA not receiving any MIDI from the Sub Phatty nor is there anymore MIDI echo. Removing highlighting from '1' under 'Channels to filter' - leaving no channel highlighted - results in MIDI being received from the Sub Phatty, but just as well, the reappearance of the MIDI echo. Additionally, now the mod and pitch bend wheel have 0 effect on the arpeggiation. The attack of each note still is heard, as is glide.

This is a rather curious predicament.
Moog Sub 37 (#0133), Ibanez M80M, & Doomy Bow
MF-102 • MF-103 • MF-105m • KE Kommander • MHI B:a (Germ. w/EQ mod) • Strymon Timeline
Previous: Model D, Taurus, Taurus III, Little Phatty SE II (Solar Edition w/CV Out mod), Sub Phatty
User avatar
mico
 
Posts: 159
Joined: Wed Apr 13, 2011 3:29 am
Location: Washington, DC


Return to The Phatty Forum

Who is online

Users browsing this forum: CommonCrawl [Bot] and 8 guests